summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-17 10:26:21 +0000
committerSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-18 14:05:57 +0000
commitd80fca527a6618595a118381a2cd2a569f85889f (patch)
tree3c26855eb3bd281825cb9e8bc77af886fdc1b658 /configure.in
parent838cd58e24a18102b8a140df9fa993fe65706828 (diff)
downloadopenocd+libswd-d80fca527a6618595a118381a2cd2a569f85889f.tar.gz
openocd+libswd-d80fca527a6618595a118381a2cd2a569f85889f.tar.bz2
openocd+libswd-d80fca527a6618595a118381a2cd2a569f85889f.tar.xz
openocd+libswd-d80fca527a6618595a118381a2cd2a569f85889f.zip
build: add autobuild jimtcl to configure scripts
Rather than having to configure/build jimtcl openocd will do this as part of its own build. To use an external jimtcl lib specify disable-internal-jimtcl to the configure step. Signed-off-by: Spencer Oliver <ntfreak@users.sourceforge.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 70dddb95..c5e81a28 100644
--- a/configure.in
+++ b/configure.in
@@ -2,6 +2,7 @@ AC_PREREQ(2.60)
AC_INIT([openocd], [0.5.0-dev],
[OpenOCD Mailing List <openocd-development@lists.berlios.de>])
AC_CONFIG_SRCDIR([src/openocd.c])
+AC_CONFIG_AUX_DIR([.])
AM_INIT_AUTOMAKE([-Wall -Wno-portability dist-bzip2 dist-zip])
AM_MAINTAINER_MODE
@@ -482,6 +483,9 @@ AC_ARG_ENABLE(minidriver_dummy,
AS_HELP_STRING([--enable-minidriver-dummy], [Enable the dummy minidriver.]),
[build_minidriver_dummy=$enableval], [build_minidriver_dummy=no])
+AC_ARG_ENABLE(internal-jimtcl,
+ AS_HELP_STRING([--enable-internal-jimtcl], [Enable internal jimtcl]),
+ [use_internal_jimtcl=$enableval], [use_internal_jimtcl=yes])
build_minidriver=no
AC_MSG_CHECKING([whether to enable ZY1000 minidriver])
@@ -757,6 +761,14 @@ else
AC_DEFINE(BUILD_BUSPIRATE, 0, [0 if you don't want the Buspirate JTAG driver.])
fi
+if test "$use_internal_jimtcl" = yes; then
+ if test -f "$srcdir/jimtcl/configure.ac"; then
+ AC_CONFIG_SUBDIRS([jimtcl])
+ else
+ AC_MSG_ERROR([jimtcl not found, run git submodule init and git submodule update.])
+ fi
+fi
+
#-- Deal with MingW/Cygwin FTD2XX issues
if test $is_win32 = yes; then
@@ -1062,6 +1074,8 @@ AM_CONDITIONAL(BITQ, test $build_bitq = yes)
AM_CONDITIONAL(MINIDRIVER, test $build_minidriver = yes)
AM_CONDITIONAL(MINIDRIVER_DUMMY, test $build_minidriver_dummy = yes)
+AM_CONDITIONAL(INTERNAL_JIMTCL, test $use_internal_jimtcl = yes)
+
# Look for environ alternatives. Possibility #1: is environ in unistd.h or stdlib.h?
AC_MSG_CHECKING([for environ in unistd.h and stdlib.h])
AC_COMPILE_IFELSE([