summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-08-20 07:54:49 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-08-20 07:54:49 +0000
commitef30f22fd3355f668b23905f50bab4671f803ab1 (patch)
tree4e24231cc99c5bf4f2fb75d9185bc0f0490be598 /configure.in
parent028e535604bf52761115c81ed65c07d0a4a64cd0 (diff)
downloadopenocd+libswd-ef30f22fd3355f668b23905f50bab4671f803ab1.tar.gz
openocd+libswd-ef30f22fd3355f668b23905f50bab4671f803ab1.tar.bz2
openocd+libswd-ef30f22fd3355f668b23905f50bab4671f803ab1.tar.xz
openocd+libswd-ef30f22fd3355f668b23905f50bab4671f803ab1.zip
- remove enable-ft2232-highspeed configure option, high speed ftdi support is now detected during the configure stage
- warning now issued if high speed ftdi device found and openocd was built using an old driver git-svn-id: svn://svn.berlios.de/openocd/trunk@2599 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 8 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 0b2bcf67..6febcb23 100644
--- a/configure.in
+++ b/configure.in
@@ -323,10 +323,6 @@ AC_ARG_ENABLE(ft2232_ftd2xx,
AS_HELP_STRING([--enable-ft2232_ftd2xx], [Enable building support for FT2232 based devices using the FTD2XX driver from ftdichip.com]),
[build_ft2232_ftd2xx=$enableval], [build_ft2232_ftd2xx=no])
-AC_ARG_ENABLE(ft2232_highspeed,
- AS_HELP_STRING([--enable-ft2232-highspeed], [Enable building support for FT2232H and FT4232H-based devices (requires >=libftd2xx-0.4.16 or >=libftdi-0.16)]),
- [want_ft2232_highspeed=$enableval], [want_ft2232_highspeed=no])
-
AC_ARG_ENABLE(amtjtagaccel,
AS_HELP_STRING([--enable-amtjtagaccel], [Enable building the Amontec JTAG-Accelerator driver]),
[build_amtjtagaccel=$enableval], [build_amtjtagaccel=no])
@@ -834,11 +830,8 @@ main( int argc, char **argv )
AC_MSG_RESULT([Skipping as we are cross-compiling])
])
-AC_MSG_CHECKING([whether to build ftd2xx highspeed device support])
-AC_MSG_RESULT([$want_ft2232_highspeed])
-if test $want_ft2232_highspeed != no; then
- AC_MSG_CHECKING([for ftd2xx highspeed device support])
- AC_COMPILE_IFELSE([
+AC_MSG_CHECKING([for ftd2xx highspeed device support])
+AC_COMPILE_IFELSE([
#include "confdefs.h"
#if IS_WIN32
#include "windows.h"
@@ -855,10 +848,9 @@ DWORD x = FT_DEVICE_4232H;
])
AC_MSG_RESULT([$build_ft2232_highspeed])
- if test $want_ft2232_highspeed = yes -a $build_ft2232_highspeed = no; then
- AC_MSG_ERROR([You need a newer FTD2XX driver (version 0.4.16 or later).])
+ if test $build_ft2232_highspeed = no; then
+ AC_MSG_WARN([You need a newer FTD2XX driver (version 2.04.16 or later).])
fi
-fi
LDFLAGS=$LDFLAGS_SAVE
CFLAGS=$CFLAGS_SAVE
@@ -903,11 +895,8 @@ main( int argc, char **argv )
AC_MSG_RESULT([Skipping as we are cross-compiling])
])
- AC_MSG_CHECKING([whether to build libftdi highspeed device support])
- AC_MSG_RESULT([$want_ft2232_highspeed])
- if test $want_ft2232_highspeed != no; then
- AC_MSG_CHECKING([for libftdi highspeed device support])
- AC_COMPILE_IFELSE([
+AC_MSG_CHECKING([for libftdi highspeed device support])
+AC_COMPILE_IFELSE([
#include <stdio.h>
#include <ftdi.h>
enum ftdi_chip_type x = TYPE_2232H;
@@ -920,10 +909,9 @@ enum ftdi_chip_type x = TYPE_2232H;
])
AC_MSG_RESULT([$build_ft2232_highspeed])
- if test $want_ft2232_highspeed = yes -a $build_ft2232_highspeed = no; then
- AC_MSG_ERROR([You need a newer libftdi version (0.16 or later).])
+ if test $build_ft2232_highspeed = no; then
+ AC_MSG_WARN([You need a newer libftdi version (0.16 or later).])
fi
- fi
# Restore the 'unexpanded ldflags'
LDFLAGS=$LDFLAGS_SAVE