summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa2a4985..8ba89512 100644
--- a/configure.in
+++ b/configure.in
@@ -277,6 +277,24 @@ AC_ARG_WITH(ftd2xx-lib,
with_ftd2xx_lib=static
])
+
+AC_ARG_ENABLE(doxygen-html,
+ AS_HELP_STRING([--disable-doxygen-html],
+ [Disable building Doxygen manual as HTML.]),
+ [doxygen_as_html=$enableval], [doxygen_as_html=yes])
+AC_SUBST(doxygen_as_html)
+AC_MSG_CHECKING([whether to build Doxygen as HTML])
+AC_MSG_RESULT($doxygen_as_html)
+
+AC_ARG_ENABLE(doxygen-pdf,
+ AS_HELP_STRING([--enable-doxygen-pdf],
+ [Enable building Doxygen manual as PDF.]),
+ [doxygen_as_pdf=$enableval], [doxygen_as_pdf=no])
+AC_SUBST(doxygen_as_pdf)
+AC_MSG_CHECKING([whether to build Doxygen as PDF])
+AC_MSG_RESULT($doxygen_as_pdf)
+
+
AC_ARG_ENABLE(gccwarnings,
AS_HELP_STRING([--disable-gccwarnings], [Disable compiler warnings]),
[gcc_warnings=$enableval], [gcc_warnings=yes])