summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7111b82a..a9e1f90a 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,7 @@ AC_CHECK_FUNCS(gettimeofday)
AC_CHECK_FUNCS(usleep)
build_bitbang=no
+build_bitq=no
is_cygwin=no
is_mingw=no
is_win32=no
@@ -51,6 +52,14 @@ AC_ARG_ENABLE(gw16012,
AS_HELP_STRING([--enable-gw16012], [Enable building support for the Gateworks GW16012 JTAG Programmer]),
[build_gw16012=$enableval], [build_gw16012=no])
+AC_ARG_ENABLE(presto,
+ AS_HELP_STRING([--enable-presto], [Enable building support for ASIX Presto Programmer]),
+ [build_presto=$enableval], [build_presto=no])
+
+AC_ARG_ENABLE(usbprog,
+ AS_HELP_STRING([--enable-usbprog], [Enable building support for the usbprog JTAG Programmer]),
+ [build_usbprog=$enableval], [build_usbprog=no])
+
AC_ARG_WITH(ftd2xx,
[AS_HELP_STRING(--with-ftd2xx,
[Where libftd2xx can be found <default=search>])],
@@ -156,6 +165,25 @@ else
AC_DEFINE(BUILD_GW16012, 0, [0 if you don't want the Gateworks GW16012 driver.])
fi
+if test $build_presto = yes; then
+ build_bitq=yes
+ AC_DEFINE(BUILD_PRESTO, 1, [1 if you want the ASIX PRESTO driver.])
+else
+ AC_DEFINE(BUILD_PRESTO, 0, [0 if you don't want the ASIX PRESTO driver.])
+fi
+
+if test $build_bitq = yes; then
+ AC_DEFINE(BUILD_BITQ, 1, [1 if you want a bitq interface.])
+else
+ AC_DEFINE(BUILD_BITQ, 0, [0 if you don't want a bitq interface.])
+fi
+
+if test $build_usbprog = yes; then
+ AC_DEFINE(BUILD_USBPROG, 1, [1 if you want the usbprog JTAG driver.])
+else
+ AC_DEFINE(BUILD_USBPROG, 0, [0 if you don't want the usbprog JTAG driver.])
+fi
+
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(openocd, 0.1)
@@ -168,10 +196,13 @@ AM_CONDITIONAL(FT2232_LIBFTDI, test $build_ft2232_libftdi = yes)
AM_CONDITIONAL(FT2232_FTD2XX, test $build_ft2232_ftd2xx = yes)
AM_CONDITIONAL(AMTJTAGACCEL, test $build_amtjtagaccel = yes)
AM_CONDITIONAL(GW16012, test $build_gw16012 = yes)
+AM_CONDITIONAL(PRESTO, test $build_presto = yes)
+AM_CONDITIONAL(USBPROG, test $build_usbprog = yes)
AM_CONDITIONAL(IS_CYGWIN, test $is_cygwin = yes)
AM_CONDITIONAL(IS_MINGW, test $is_mingw = yes)
AM_CONDITIONAL(IS_WIN32, test $is_win32 = yes)
AM_CONDITIONAL(FTD2XXDIR, test $with_ftd2xx != search)
+AM_CONDITIONAL(BITQ, test $build_bitq = yes)
AC_LANG_C
AC_PROG_CC