summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 090d934b..3b4a7251 100644
--- a/configure.in
+++ b/configure.in
@@ -488,6 +488,10 @@ AC_ARG_ENABLE(internal-jimtcl,
AS_HELP_STRING([--disable-internal-jimtcl], [Disable building internal jimtcl]),
[use_internal_jimtcl=$enableval], [use_internal_jimtcl=yes])
+AC_ARG_ENABLE(internal-libswd,
+ AS_HELP_STRING([--disable-internal-libswd], [Disable building internal libswd]),
+ [use_internal_libswd=$enableval], [use_internal_libswd=yes])
+
build_minidriver=no
AC_MSG_CHECKING([whether to enable ZY1000 minidriver])
if test $build_zy1000 = yes; then
@@ -770,6 +774,14 @@ if test "$use_internal_jimtcl" = yes; then
fi
fi
+if test "$use_internal_libswd" = yes; then
+ if test -f "$srcdir/submodules/libswd/configure.ac"; then
+ AX_CONFIG_SUBDIR_OPTION([submodules/libswd])
+ else
+ AC_MSG_ERROR([libswd not found, run git submodule init and git submodule update.])
+ fi
+fi
+
#-- Deal with MingW/Cygwin FTD2XX issues
if test $is_win32 = yes; then
@@ -1069,6 +1081,7 @@ AM_CONDITIONAL(MINIDRIVER, test $build_minidriver = yes)
AM_CONDITIONAL(MINIDRIVER_DUMMY, test $build_minidriver_dummy = yes)
AM_CONDITIONAL(INTERNAL_JIMTCL, test $use_internal_jimtcl = yes)
+AM_CONDITIONAL(INTERNAL_LIBSWD, test $use_internal_libswd = yes)
# Look for environ alternatives. Possibility #1: is environ in unistd.h or stdlib.h?
AC_MSG_CHECKING([for environ in unistd.h and stdlib.h])