summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ba70f997..ae35f555 100644
--- a/configure.in
+++ b/configure.in
@@ -30,6 +30,10 @@ AC_ARG_ENABLE(parport,
AS_HELP_STRING([--enable-parport], [Enable building the pc parallel port driver]),
[build_parport=$enableval], [build_parport=no])
+AC_ARG_ENABLE(dummy,
+ AS_HELP_STRING([--enable-dummy], [Enable building the dummy port driver]),
+ [build_dummy=$enableval], [build_dummy=no])
+
case "${host_cpu}" in
i?86|x86*)
AC_ARG_ENABLE(parport_ppdev,
@@ -144,6 +148,14 @@ else
AC_DEFINE(BUILD_PARPORT, 0, [0 if you don't want parport.])
fi
+if test $build_dummy = yes; then
+ build_bitbang=yes
+ AC_DEFINE(BUILD_DUMMY, 1, [1 if you want dummy driver.])
+else
+ AC_DEFINE(BUILD_DUMMY, 0, [0 if you don't want dummy driver.])
+fi
+
+
if test $build_ep93xx = yes; then
build_bitbang=yes
AC_DEFINE(BUILD_EP93XX, 1, [1 if you want ep93xx.])
@@ -243,6 +255,7 @@ AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(openocd, 1.0)
AM_CONDITIONAL(PARPORT, test $build_parport = yes)
+AM_CONDITIONAL(DUMMY, test $build_dummy = yes)
AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(ECOSBOARD, test $build_ecosboard = yes)