summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am81
1 files changed, 47 insertions, 34 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index d448197a..e1224519 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -6,65 +6,78 @@ AM_CPPFLAGS = \
METASOURCES = AUTO
noinst_LTLIBRARIES = libflash.la
libflash_la_SOURCES = \
- arm_nandio.c \
- flash.c \
- lpc2000.c \
- lpc288x.c \
- lpc2900.c \
+ $(FLASH_SRCS) \
+ $(NAND_SRCS) \
+ mflash.c
+
+FLASH_SRCS = \
cfi.c \
non_cfi.c \
- at91sam7.c \
+ faux.c \
+ $(FLASH_DEVICES_SRCS) \
+ flash.c
+
+FLASH_DEVICES_SRCS = \
+ aduc702x.c \
at91sam3.c \
- davinci_nand.c \
+ at91sam7.c \
+ avrf.c \
+ ecos.c \
+ lpc2000.c \
+ lpc288x.c \
+ lpc2900.c \
+ ocl.c \
+ pic32mx.c \
+ stellaris.c \
+ stm32x.c \
str7x.c \
str9x.c \
- aduc702x.c \
- nand.c \
+ str9xpec.c \
+ tms470.c
+
+NAND_SRCS = \
+ arm_nandio.c \
nand_ecc.c \
nand_ecc_kw.c \
+ $(NAND_DEVICES_SRCS) \
+ nand.c
+
+NAND_DEVICES_SRCS = \
+ davinci_nand.c \
lpc3180_nand_controller.c \
- stellaris.c \
- str9xpec.c \
- stm32x.c \
- tms470.c \
- ecos.c \
+ mx3_nand.c \
orion_nand.c \
s3c24xx_nand.c \
s3c2410_nand.c \
s3c2412_nand.c \
s3c2440_nand.c \
- s3c2443_nand.c \
- ocl.c \
- mflash.c \
- pic32mx.c \
- avrf.c \
- faux.c \
- mx3_nand.c
+ s3c2443_nand.c
+
noinst_HEADERS = \
arm_nandio.h \
+ at91sam7.h \
+ at91sam3.h \
+ avrf.h \
+ cfi.h \
flash.h \
lpc2000.h \
lpc288x.h \
lpc2900.h \
- cfi.h \
+ lpc3180_nand_controller.h \
+ mflash.h \
+ mx3_nand.h \
non_cfi.h \
- at91sam7.h \
- at91sam3.h \
- str7x.h \
- str9x.h \
nand.h \
- lpc3180_nand_controller.h \
+ ocl.h \
+ pic32mx.h \
stellaris.h \
- str9xpec.h \
stm32x.h \
+ str7x.h \
+ str9x.h \
+ str9xpec.h \
tms470.h \
s3c24xx_nand.h \
- s3c24xx_regs_nand.h \
- mflash.h \
- ocl.h \
- pic32mx.h \
- avrf.h \
- mx3_nand.h
+ s3c24xx_regs_nand.h
MAINTAINERCLEANFILES = $(srcdir)/Makefile.in