summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d05d375..2fd5e323 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,14 @@ SUBDIRS = src doc
EXTRA_DIST = Doxyfile
+docs: pdf html doxygen
+
+doxygen::
+ doxygen Doxyfile 2>&1 | perl tools/logger.pl > doxygen.log
+
+doxygen-clean:
+ rm -f -r doxygen doxygen.log
+
MAINTAINERCLEANFILES = \
configure \
Makefile.in \