summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-09-19 09:46:09 +0000
committerChris Lord <chris@openedhand.com>2005-09-19 09:46:09 +0000
commit0a28d7e311e13c9a10d9db5f049bac9df23c1762 (patch)
tree842e1f3de3ea8216814406d5ae2a3e67d6afa2b2
parent72d61f6fdd08a41b66554e05855e6043d8291344 (diff)
downloadopenembedded-core-0a28d7e311e13c9a10d9db5f049bac9df23c1762.tar.gz
openembedded-core-0a28d7e311e13c9a10d9db5f049bac9df23c1762.tar.bz2
openembedded-core-0a28d7e311e13c9a10d9db5f049bac9df23c1762.tar.xz
openembedded-core-0a28d7e311e13c9a10d9db5f049bac9df23c1762.zip
Add gconf-dbus
git-svn-id: https://svn.o-hand.com/repos/poky@24 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rwxr-xr-xopenembedded/packages/gnome/gconf-dbus/69gconfd-dbus3
-rwxr-xr-xopenembedded/packages/gnome/gconf-dbus/gconf-dbus-update.patch31
-rwxr-xr-xopenembedded/packages/gnome/gconf-dbus_cvs.bb36
3 files changed, 70 insertions, 0 deletions
diff --git a/openembedded/packages/gnome/gconf-dbus/69gconfd-dbus b/openembedded/packages/gnome/gconf-dbus/69gconfd-dbus
new file mode 100755
index 000000000..c2add042f
--- /dev/null
+++ b/openembedded/packages/gnome/gconf-dbus/69gconfd-dbus
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/libexec/gconfd-2 &
diff --git a/openembedded/packages/gnome/gconf-dbus/gconf-dbus-update.patch b/openembedded/packages/gnome/gconf-dbus/gconf-dbus-update.patch
new file mode 100755
index 000000000..9870078b8
--- /dev/null
+++ b/openembedded/packages/gnome/gconf-dbus/gconf-dbus-update.patch
@@ -0,0 +1,31 @@
+? gconf/gconf.service
+Index: gconf/Makefile.am
+===================================================================
+RCS file: /cvs/gnome/gconf/gconf/Makefile.am,v
+retrieving revision 1.78.4.8
+diff -u -r1.78.4.8 Makefile.am
+--- gconf/Makefile.am 21 Dec 2003 14:21:15 -0000 1.78.4.8
++++ gconf/Makefile.am 22 Jan 2005 00:30:13 -0000
+@@ -155,6 +155,7 @@
+
+ libgconf_2_la_LDFLAGS = -version-info $(GCONF_CURRENT):$(GCONF_REVISION):$(GCONF_AGE) -no-undefined
+ libgconf_2_la_LIBADD = $(INTLLIBS) $(DEPENDENT_LIBS) $(GCONF_IPC_LIBS)
++libgconf_2_la_CFLAGS = $(AM_CFLAGS)
+
+ if HAVE_DBUS
+ servicedir = $(DBUS_SERVICE_DIR)
+Index: backends/Makefile.am
+===================================================================
+RCS file: /cvs/gnome/gconf/backends/Makefile.am,v
+retrieving revision 1.30
+diff -u -r1.30 Makefile.am
+--- backends/Makefile.am 3 Nov 2003 00:19:33 -0000 1.30
++++ backends/Makefile.am 22 Jan 2005 00:30:14 -0000
+@@ -17,6 +17,7 @@
+
+ libgconfbackend_oldxml_la_LDFLAGS = -avoid-version -module -no-undefined
+ libgconfbackend_oldxml_la_LIBADD = $(DEPENDENT_WITH_XML_LIBS) $(top_builddir)/gconf/libgconf-$(MAJOR_VERSION).la
++libgconfbackend_oldxml_la_CFLAGS = $(AM_CFLAGS)
+
+ libgconfbackend_xml_la_SOURCES = \
+ markup-backend.c \
diff --git a/openembedded/packages/gnome/gconf-dbus_cvs.bb b/openembedded/packages/gnome/gconf-dbus_cvs.bb
new file mode 100755
index 000000000..65deaf5b2
--- /dev/null
+++ b/openembedded/packages/gnome/gconf-dbus_cvs.bb
@@ -0,0 +1,36 @@
+SECTION = "x11/utils"
+DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
+DESCRIPTION = "Settings daemon using DBUS for communication."
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+PROVIDES = "gconf"
+RPROVIDES = "gconf"
+
+PV = "0.0cvs${CVSDATE}"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gconf;tag=gconf-dbus-2-6 \
+ file://gconf-dbus-update.patch;patch=1;pnum=0 \
+ file://69gconfd-dbus"
+
+FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir}"
+
+S = "${WORKDIR}/gconf"
+
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
+
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+do_stage() {
+ oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gconf/2/gconf/
+ ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+ install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
+}