summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:26:45 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:26:45 +0100
commit19592cf696d73e23beef34533958596ea4419696 (patch)
tree8e8cbca411104dff52118bc0af3ea0c0b71cc1f1
parent826ed806376be744436a85b9af03f031ca6106c4 (diff)
downloadopenembedded-core-19592cf696d73e23beef34533958596ea4419696.tar.gz
openembedded-core-19592cf696d73e23beef34533958596ea4419696.tar.bz2
openembedded-core-19592cf696d73e23beef34533958596ea4419696.tar.xz
openembedded-core-19592cf696d73e23beef34533958596ea4419696.zip
flac: Convert to autotools_stafe
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta/packages/flac/flac_1.1.2.bb50
1 files changed, 2 insertions, 48 deletions
diff --git a/meta/packages/flac/flac_1.1.2.bb b/meta/packages/flac/flac_1.1.2.bb
index 85ffc9beb..3d0211f75 100644
--- a/meta/packages/flac/flac_1.1.2.bb
+++ b/meta/packages/flac/flac_1.1.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "FLAC is a Free Lossless Audio Codec."
LICENSE = "BSD GPL"
SECTION = "libs"
DEPENDS = "libogg"
-PR = "r5"
+PR = "r6"
SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
file://disable-xmms-plugin.patch;patch=1 \
@@ -10,7 +10,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
S = "${WORKDIR}/flac-${PV}"
-inherit autotools
+inherit autotools_stage
EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
--with-ogg-libraries=${STAGING_LIBDIR} \
@@ -36,49 +36,3 @@ do_configure () {
sed -i 's/-Wl,-read_only_relocs,warning//g' src/libFLAC/Makefile
}
-do_stage () {
- install -d ${STAGING_DATADIR}/aclocal
-
- oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/OggFLAC
- install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
-
- install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
- install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
- install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
- install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/FLAC
- install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
- install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
- install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
- install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
- install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
- install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
- install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
- install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
- install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
- install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
- install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
- install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
- install -m 0644 ${S}/include/FLAC/callback.h ${STAGING_INCDIR}/FLAC/callback.h
- install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/FLAC++
- install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
- install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
- install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
- install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
- install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
- install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/OggFLAC++
- install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
- install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
- install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
- install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
- install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
-}