summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-04-15 08:45:15 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-02 15:41:34 +0100
commit214d1f7433fd8571c3e0920624ce07f31c7f08c9 (patch)
tree60bcbf02751331e45b6d8782a4318a184262f70e
parent231d3a534cdf75b3db588329fbd5d2a0fbbfba5e (diff)
downloadopenembedded-core-214d1f7433fd8571c3e0920624ce07f31c7f08c9.tar.gz
openembedded-core-214d1f7433fd8571c3e0920624ce07f31c7f08c9.tar.bz2
openembedded-core-214d1f7433fd8571c3e0920624ce07f31c7f08c9.tar.xz
openembedded-core-214d1f7433fd8571c3e0920624ce07f31c7f08c9.zip
Move the python version check into the python package
This ensures the check is run for anyone using the package, including setup.py, though it's sad that it's necessary, since all it really wants is __version__. Ideally, we'd avoid the version check entirely in favor of checking for functionality, but that's rather difficult with language constructs like context managers, so this'll do for now. (Bitbake rev: f936f1c0edf70860ea0f39ec1a500ba43b56f289) Signed-off-by: Chris Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rwxr-xr-xbitbake/bin/bitbake6
-rw-r--r--bitbake/lib/bb/__init__.py4
2 files changed, 5 insertions, 5 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index a8d6fd9d0..82af9a719 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -22,12 +22,8 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-import sys
-if sys.version_info < (2, 6, 0):
- print "Sorry, python 2.6.0 or later is required for this version of bitbake"
- sys.exit(1)
-
import os
+import sys
sys.path.insert(0, os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])),
'lib'))
diff --git a/bitbake/lib/bb/__init__.py b/bitbake/lib/bb/__init__.py
index bf2f35a73..e4a970c64 100644
--- a/bitbake/lib/bb/__init__.py
+++ b/bitbake/lib/bb/__init__.py
@@ -23,6 +23,10 @@
__version__ = "1.11.0"
+import sys
+if sys.version_info < (2, 6, 0):
+ raise RuntimeError("Sorry, python 2.6.0 or later is required for this version of bitbake")
+
import os
import bb.msg