summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-01-30 22:04:03 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-01-30 22:04:03 +0000
commit321fc54706f4dfc90786e336a87f262a64aa9007 (patch)
treeddb108f2b021a08fb48d76f5bf3730f16482ea9d
parent74fb622cd047c798bc19b555948340ccff1d75d4 (diff)
downloadopenembedded-core-321fc54706f4dfc90786e336a87f262a64aa9007.tar.gz
openembedded-core-321fc54706f4dfc90786e336a87f262a64aa9007.tar.bz2
openembedded-core-321fc54706f4dfc90786e336a87f262a64aa9007.tar.xz
openembedded-core-321fc54706f4dfc90786e336a87f262a64aa9007.zip
hal: split libraries to separate packages
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3644 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/hal/hal_0.5.9.1.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/packages/hal/hal_0.5.9.1.bb b/meta/packages/hal/hal_0.5.9.1.bb
index 9cfc28a03..8422647ac 100644
--- a/meta/packages/hal/hal_0.5.9.1.bb
+++ b/meta/packages/hal/hal_0.5.9.1.bb
@@ -7,7 +7,7 @@ DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
RDEPENDS_${PN} += "udev hal-info"
RRECOMMENDS_${PN} += "udev-utils"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
file://sg-inhibit.patch;patch=1 \
@@ -46,7 +46,7 @@ do_stage() {
# At the time the postinst runs, dbus might not be setup so only restart if running
pkg_postinst_hal () {
- # can't do this offline
+ # can not do this offline
if [ "x$D" != "x" ]; then
exit 1
fi
@@ -68,6 +68,11 @@ pkg_postrm_hal () {
delgroup haldaemon || true
}
+PACKAGES =+ "libhal libhal-storage"
+
+FILES_libhal = "${libdir}/libhal.so.*"
+FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
+
FILES_${PN} = "${sysconfdir} \
${bindir}/lshal \
${bindir}/hal-find-by-capability \