summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-14 09:34:33 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-14 09:34:33 +0000
commit3f659983bff5002f1e61f75a4cdf13ee9c2575d1 (patch)
tree0e832a7e1eb8e43fb25e317a797221074c27d330
parent11ca8a4dd9e0882bdfeeebc81518245ab27f6cb9 (diff)
downloadopenembedded-core-3f659983bff5002f1e61f75a4cdf13ee9c2575d1.tar.gz
openembedded-core-3f659983bff5002f1e61f75a4cdf13ee9c2575d1.tar.bz2
openembedded-core-3f659983bff5002f1e61f75a4cdf13ee9c2575d1.tar.xz
openembedded-core-3f659983bff5002f1e61f75a4cdf13ee9c2575d1.zip
gpgme: added 1.1.4 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3992 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/gpgme/gpgme_1.1.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/gpgme/gpgme_1.1.4.bb b/meta/packages/gpgme/gpgme_1.1.4.bb
new file mode 100644
index 000000000..d78cc88ce
--- /dev/null
+++ b/meta/packages/gpgme/gpgme_1.1.4.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
+PR = "r1"
+
+DEPENDS = "libgpg-error pth libassuan"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test --with-gpg=${bindir}/gpg --without-gpgsm"
+
+inherit autotools binconfig
+
+do_stage() {
+ autotools_stage_includes
+
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
+}
+