summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-22 17:30:04 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-22 17:30:04 +0100
commit45543f77498f753646b88e50fda006f1493b1419 (patch)
tree523d02655c5c0b94d5d67053917a664ae01b2c54
parentd7568d312b2f697511d225cfa13ecde96a9a6b92 (diff)
downloadopenembedded-core-45543f77498f753646b88e50fda006f1493b1419.tar.gz
openembedded-core-45543f77498f753646b88e50fda006f1493b1419.tar.bz2
openembedded-core-45543f77498f753646b88e50fda006f1493b1419.tar.xz
openembedded-core-45543f77498f753646b88e50fda006f1493b1419.zip
consolekit: Add 0.3.0 from OE but disable policykit interaction
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta-moblin/packages/consolekit/consolekit_0.3.0.bb19
-rw-r--r--meta-moblin/packages/consolekit/files/nopolkit.patch16
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-moblin/packages/consolekit/consolekit_0.3.0.bb b/meta-moblin/packages/consolekit/consolekit_0.3.0.bb
new file mode 100644
index 000000000..b4656c099
--- /dev/null
+++ b/meta-moblin/packages/consolekit/consolekit_0.3.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login sessions, and seats."
+LICENSE = "GPLv2"
+DEPENDS = "dbus"
+
+inherit gnome
+
+SRC_URI = "http://people.freedesktop.org/~mccann/dist/ConsoleKit-${PV}.tar.bz2 \
+ file://nopolkit.patch;patch=1"
+S = "${WORKDIR}/ConsoleKit-${PV}"
+
+do_stage () {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/ConsoleKit ${datadir}/dbus-1 ${datadir}/PolicyKit"
+
+
+
+
diff --git a/meta-moblin/packages/consolekit/files/nopolkit.patch b/meta-moblin/packages/consolekit/files/nopolkit.patch
new file mode 100644
index 000000000..bebbcafff
--- /dev/null
+++ b/meta-moblin/packages/consolekit/files/nopolkit.patch
@@ -0,0 +1,16 @@
+Index: ConsoleKit-0.3.0/configure.ac
+===================================================================
+--- ConsoleKit-0.3.0.orig/configure.ac 2009-05-22 12:53:27.000000000 +0100
++++ ConsoleKit-0.3.0/configure.ac 2009-05-22 12:53:56.000000000 +0100
+@@ -55,10 +55,7 @@
+ gthread-2.0 >= $GLIB_REQUIRED_VERSION
+ )
+
+-PKG_CHECK_MODULES(POLKIT,
+- polkit >= $POLKIT_REQUIRED_VERSION,
+- have_polkit=yes,
+- have_polkit=no)
++have_polkit=no
+ if test "x$have_polkit" = "xyes" ; then
+ AC_DEFINE(HAVE_POLKIT, [], [Define if we have polkit])
+ fi