summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-01-11 16:40:04 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-30 12:09:52 -0800
commit483ee172cf522969a7e5eb7f81ba2be412db9ee4 (patch)
tree5b5db49d3023fa27e18f63550f0e1968fd5312bd
parent2c32f494ccf1721d0888bde59be41ba05e221d33 (diff)
downloadopenembedded-core-483ee172cf522969a7e5eb7f81ba2be412db9ee4.tar.gz
openembedded-core-483ee172cf522969a7e5eb7f81ba2be412db9ee4.tar.bz2
openembedded-core-483ee172cf522969a7e5eb7f81ba2be412db9ee4.tar.xz
openembedded-core-483ee172cf522969a7e5eb7f81ba2be412db9ee4.zip
libzypp: upgrade to newer git version
this works with rpm 5.4.0 Signed-off-by: Qing He <qing.he@intel.com>
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc2
-rw-r--r--meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch25
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb4
3 files changed, 29 insertions, 2 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index 804667e10..de3a1e386 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -76,7 +76,7 @@ SRCREV_pn-libxcb-nativesdk ??= "625ed596cae6dd8175aeb6cb6f26784928042f22"
SRCREV_pn-libxext ??= "d1f3bc77a48c8e42771579e3fdf3370b35d3209d"
SRCREV_pn-libxext-nativesdk ??= "d1f3bc77a48c8e42771579e3fdf3370b35d3209d"
SRCREV_pn-libxi ??= "d0326fe8cdbb08d4f52d79fd3fd4e1b2a0951d5e"
-SRCREV_pn-libzypp = "4494797d5b0369365b1af63921de45b197ead64f"
+SRCREV_pn-libzypp = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
SRCREV_pn-linux-firmware ??= "40c0f950be7040614dc45df54e25e54d00e3b73b"
SRCREV_pn-linux-openmoko ??= "5ccaca2adb1c37b5955a4733f68ae08a755e3d78"
SRCREV_pn-linux-omap ??= "58cf2f1425abfd3a449f9fe985e48be2d2555022"
diff --git a/meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch b/meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch
new file mode 100644
index 000000000..f15bb68d5
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch
@@ -0,0 +1,25 @@
+diff --git a/zypp/target/rpm/librpmDb.cc b/zypp/target/rpm/librpmDb.cc
+index 1689fbb..4999cd9 100644
+--- a/zypp/target/rpm/librpmDb.cc
++++ b/zypp/target/rpm/librpmDb.cc
+@@ -60,20 +60,6 @@ public:
+ const char * root = ( _root == "/" ? NULL : _root.asString().c_str() );
+ int perms = 0644;
+
+- // check whether to create a new db
+- PathInfo master( _root + _dbPath + "Packages" );
+- if ( ! master.isFile() )
+- {
+- // init database
+- int res = ::rpmdbInit( root, perms );
+- if ( res )
+- {
+- ERR << "rpmdbInit error(" << res << "): " << *this << endl;
+- _error = shared_ptr<RpmInitException>(new RpmInitException(_root, _dbPath));
+- ZYPP_THROW(*_error);
+- }
+- }
+-
+ // open database
+ int res = ::rpmdbOpen( root, &_db, (readonly_r ? O_RDONLY : O_RDWR ), perms );
+ if ( res || !_db )
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index c65ae46b0..b9110eb09 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -17,7 +17,9 @@ PR = "r6"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
- file://rpm5.patch "
+ file://rpm5.patch \
+ file://rpm5-no-rpmdbinit.patch \
+ "
SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"