summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-04-14 23:12:37 +0000
committerRichard Purdie <richard@openedhand.com>2008-04-14 23:12:37 +0000
commit4c6ff89d2ce3ab80a7101909904c4987856ca2ac (patch)
tree2a5bdbaa6fdb174b794b7231a7161698f45de968
parentb38bc533f25bf0a6422775e81b2406241c72b9c7 (diff)
downloadopenembedded-core-4c6ff89d2ce3ab80a7101909904c4987856ca2ac.tar.gz
openembedded-core-4c6ff89d2ce3ab80a7101909904c4987856ca2ac.tar.bz2
openembedded-core-4c6ff89d2ce3ab80a7101909904c4987856ca2ac.tar.xz
openembedded-core-4c6ff89d2ce3ab80a7101909904c4987856ca2ac.zip
cario: Add fixes for libtool 2.2.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4265 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/cairo/cairo-1.4.14/configure_fix.patch69
-rw-r--r--meta/packages/cairo/cairo_1.4.14.bb5
2 files changed, 72 insertions, 2 deletions
diff --git a/meta/packages/cairo/cairo-1.4.14/configure_fix.patch b/meta/packages/cairo/cairo-1.4.14/configure_fix.patch
new file mode 100644
index 000000000..04993bb0b
--- /dev/null
+++ b/meta/packages/cairo/cairo-1.4.14/configure_fix.patch
@@ -0,0 +1,69 @@
+Libtool 2.2.2 can't cope unless the LT_ variables are marked as AC_SUBST
+as otherwise autofoo tries to expand them, fails and gets upset.
+
+You can't conditionally add AC_PROG_CXX to a configure.ac file since the
+mere mention of it triggers some internals which then get upset it if
+wasn't really called at configure time.
+
+Referring to a .cpp file in Makefiles without calling AC_PROG_CXX is
+now also a fatal error. Easiest fix is to drop the CXX stuff entirely.
+
+RP - 14/4/08
+
+Index: cairo-1.4.14/configure.in
+===================================================================
+--- cairo-1.4.14.orig/configure.in 2008-04-14 14:50:16.000000000 +0100
++++ cairo-1.4.14/configure.in 2008-04-14 15:05:59.000000000 +0100
+@@ -23,15 +23,18 @@
+
+ # Increment if the interface has additions, changes, removals.
+ LT_CURRENT=13
++AC_SUBST(LT_CURRENT)
+
+ # Increment any time the source changes; set to
+ # 0 if you increment CURRENT
+ LT_REVISION=7
++AC_SUBST(LT_REVISION)
+
+ # Increment if any interfaces have been added; set to 0
+ # if any interfaces have been removed. removal has
+ # precedence over adding, so set to 0 if both happened.
+ LT_AGE=11
++AC_SUBST(LT_AGE)
+
+ dnl ===========================================================================
+
+@@ -342,9 +345,6 @@
+ esac
+ ])
+
+-if test "x$use_beos" = "xyes"; then
+- AC_PROG_CXX
+-fi
+
+ dnl ===========================================================================
+
+Index: cairo-1.4.14/boilerplate/Makefile.am
+===================================================================
+--- cairo-1.4.14.orig/boilerplate/Makefile.am 2008-04-14 15:08:47.000000000 +0100
++++ cairo-1.4.14/boilerplate/Makefile.am 2008-04-14 15:08:57.000000000 +0100
+@@ -9,7 +9,6 @@
+ libcairoboilerplate_la_LIBADD = $(top_builddir)/src/libcairo.la $(CAIRO_LDADD)
+
+ if CAIRO_HAS_BEOS_SURFACE
+-libcairoboilerplate_la_SOURCES += cairo-boilerplate-beos.cpp
+ libcairoboilerplate_la_SOURCES += cairo-boilerplate-beos-private.h
+ # BeOS system headers trigger this warning
+ libcairoboilerplate_la_CXXFLAGS = -Wno-multichar
+Index: cairo-1.4.14/src/Makefile.am
+===================================================================
+--- cairo-1.4.14.orig/src/Makefile.am 2008-04-14 15:08:25.000000000 +0100
++++ cairo-1.4.14/src/Makefile.am 2008-04-14 15:08:38.000000000 +0100
+@@ -97,7 +97,6 @@
+ libcairo_beos_sources =
+ if CAIRO_HAS_BEOS_SURFACE
+ libcairo_beos_headers = cairo-beos.h
+-libcairo_beos_sources += cairo-beos-surface.cpp
+ backend_pkgconfigs += cairo-beos.pc
+
+ noinst_LTLIBRARIES = libcairo_beos.la
diff --git a/meta/packages/cairo/cairo_1.4.14.bb b/meta/packages/cairo/cairo_1.4.14.bb
index 845e14fc2..116c79810 100644
--- a/meta/packages/cairo/cairo_1.4.14.bb
+++ b/meta/packages/cairo/cairo_1.4.14.bb
@@ -1,6 +1,7 @@
require cairo.inc
-SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz"
+SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz \
+ file://configure_fix.patch;patch=1 "
-PR = "r0"
+PR = "r1"