summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Hatle <mhatle@windriver.com>2010-07-23 08:18:07 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 01:23:53 +0100
commit4f19548bfb5e9259eb0e38bbe3886f139d6b1f0a (patch)
tree0dccb8c6d15be0f60ce48f207bc5949993340519
parent5e3da1b94e20c878a77ce1a166a46e59b1ff9c08 (diff)
downloadopenembedded-core-4f19548bfb5e9259eb0e38bbe3886f139d6b1f0a.tar.gz
openembedded-core-4f19548bfb5e9259eb0e38bbe3886f139d6b1f0a.tar.bz2
openembedded-core-4f19548bfb5e9259eb0e38bbe3886f139d6b1f0a.tar.xz
openembedded-core-4f19548bfb5e9259eb0e38bbe3886f139d6b1f0a.zip
prelink: Add prelink-native
Add the new cross prelink support as the prelink-native integration. Set the prelinker to use the prelink-cross.git repository as the upstream. Note: libiberty.a is required on the host at this time Signed-off-by: Mark Hatle <mhatle@windriver.com>
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc2
-rw-r--r--meta/packages/prelink/prelink_git.bb (renamed from meta/packages/prelink/prelink_20100106.bb)17
2 files changed, 13 insertions, 6 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index d3d59274a..44723a0a6 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -104,6 +104,8 @@ SRCREV_pn-oprofileui ??= "197"
SRCREV_pn-osc-native ??= "9096"
SRCREV_pn-owl-video ??= "394"
SRCREV_pn-pkgconfig ??= "66d49f1375fec838bcd301bb4ca2ef76cee0e47c"
+SRCREV_pn-prelink ??= "909470ee441237563d6236c505cb2d02ddc48704"
+SRCREV_pn-prelink-native ??= "909470ee441237563d6236c505cb2d02ddc48704"
SRCREV_pn-psplash ??= "424"
SRCREV_pn-pseudo ??= "973e40da8e5abb080cc0b9c9eaff4d84dea5b42c"
SRCREV_pn-pseudo-native ??= "973e40da8e5abb080cc0b9c9eaff4d84dea5b42c"
diff --git a/meta/packages/prelink/prelink_20100106.bb b/meta/packages/prelink/prelink_git.bb
index a84aaa267..06078ed68 100644
--- a/meta/packages/prelink/prelink_20100106.bb
+++ b/meta/packages/prelink/prelink_git.bb
@@ -1,12 +1,14 @@
SECTION = "devel"
-DEPENDS = "elfutils"
+# Need binutils for libiberty.a
+DEPENDS = "elfutils binutils"
DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
-LICENSE = "GPL"
+LICENSE = "GPLv2"
+PV = "1.0+git${SRCPV}"
PR = "r0"
-SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
+SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
file://prelink.conf \
file://prelink.cron.daily \
file://prelink.default"
@@ -14,12 +16,15 @@ SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
TARGET_OS_ORIG := "${TARGET_OS}"
OVERRIDES_append = ":${TARGET_OS_ORIG}"
-S = "${WORKDIR}/prelink"
-
-EXTRA_OECONF = "--disable-64bit"
+S = "${WORKDIR}/git/trunk"
inherit autotools
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
+ --with-bugurl=http://bugzilla.pokylinux.org/"
+
do_install_append () {
install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf