summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-04-09 18:00:28 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-03 15:00:24 +0100
commit4fb71999fad9e844850831caf2431ee8731787db (patch)
tree25d02806b7c3a968873008edabe50d63a2ab34a3
parente1f3a0bcce7b24d6c48e6c92c54bcb03858a5748 (diff)
downloadopenembedded-core-4fb71999fad9e844850831caf2431ee8731787db.tar.gz
openembedded-core-4fb71999fad9e844850831caf2431ee8731787db.tar.bz2
openembedded-core-4fb71999fad9e844850831caf2431ee8731787db.tar.xz
openembedded-core-4fb71999fad9e844850831caf2431ee8731787db.zip
mesa: add missing flex-native/bison-native deps
A quick glance at configure.ac shows that both are required to build mesa, but we were relying on their being built implicitly via other recipes in the dependency chain. Make it explicit. Signed-off-by: Christopher Larson <chris_larson@mentor.com>
-rw-r--r--meta/recipes-graphics/mesa/mesa-common.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-common.inc b/meta/recipes-graphics/mesa/mesa-common.inc
index 1c376b773..f697e673e 100644
--- a/meta/recipes-graphics/mesa/mesa-common.inc
+++ b/meta/recipes-graphics/mesa/mesa-common.inc
@@ -19,7 +19,7 @@ PE = "2"
PROTO_DEPS = "xf86driproto glproto"
LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
-DEPENDS = "makedepend-native python-native ${PROTO_DEPS} ${LIB_DEPS}"
+DEPENDS = "makedepend-native python-native flex-native bison-native ${PROTO_DEPS} ${LIB_DEPS}"
PROVIDES = "virtual/libgl"