summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-14 16:37:56 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-14 16:37:56 +0000
commit50d9ca76b42a4b777e88123a060e8cfb284f4a40 (patch)
tree28d601dfd04e05d5bced14a023180c3f433316bc
parent24c24ecf0d407128ecfdd71234a1150122dbe1da (diff)
downloadopenembedded-core-50d9ca76b42a4b777e88123a060e8cfb284f4a40.tar.gz
openembedded-core-50d9ca76b42a4b777e88123a060e8cfb284f4a40.tar.bz2
openembedded-core-50d9ca76b42a4b777e88123a060e8cfb284f4a40.tar.xz
openembedded-core-50d9ca76b42a4b777e88123a060e8cfb284f4a40.zip
qemu: Add small fix to gl patch
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta/packages/qemu/qemu-git/qemu-git-qemugl-host.patch380
-rw-r--r--meta/packages/qemu/qemu_git.bb2
2 files changed, 182 insertions, 200 deletions
diff --git a/meta/packages/qemu/qemu-git/qemu-git-qemugl-host.patch b/meta/packages/qemu/qemu-git/qemu-git-qemugl-host.patch
index cfa091816..00d9ca7cc 100644
--- a/meta/packages/qemu/qemu-git/qemu-git-qemugl-host.patch
+++ b/meta/packages/qemu/qemu-git/qemu-git-qemugl-host.patch
@@ -1,8 +1,8 @@
-diff --git a/Makefile.target b/Makefile.target
-index f33f762..d1eb876 100644
---- a/Makefile.target
-+++ b/Makefile.target
-@@ -153,6 +153,10 @@ endif
+Index: git/Makefile.target
+===================================================================
+--- git.orig/Makefile.target 2009-12-02 13:13:56.000000000 +0000
++++ git/Makefile.target 2010-01-14 16:34:58.000000000 +0000
+@@ -153,6 +153,10 @@
CPPFLAGS+=-I$(SRC_PATH)/fpu
LIBOBJS+= op_helper.o helper.o
@@ -13,7 +13,7 @@ index f33f762..d1eb876 100644
ifeq ($(TARGET_BASE_ARCH), arm)
LIBOBJS+= neon_helper.o iwmmxt_helper.o
endif
-@@ -224,6 +228,21 @@ op_helper.o: CFLAGS += $(HELPER_CFLAGS) $(I386_CFLAGS)
+@@ -224,6 +228,21 @@
cpu-exec.o: CFLAGS += $(HELPER_CFLAGS)
@@ -35,7 +35,7 @@ index f33f762..d1eb876 100644
#########################################################
# Linux user emulator target
-@@ -584,7 +603,7 @@ OBJS+= fdc.o mc146818rtc.o serial.o i8259.o i8254.o pcspk.o pc.o
+@@ -584,7 +603,7 @@
OBJS+= cirrus_vga.o apic.o parallel.o acpi.o piix_pci.o
OBJS+= usb-uhci.o vmmouse.o vmport.o vmware_vga.o hpet.o
OBJS += device-hotplug.o pci-hotplug.o
@@ -44,7 +44,7 @@ index f33f762..d1eb876 100644
endif
ifeq ($(TARGET_BASE_ARCH), ppc)
CPPFLAGS += -DHAS_AUDIO -DHAS_AUDIO_CHOICE
-@@ -727,7 +746,7 @@ endif
+@@ -727,7 +746,7 @@
$(QEMU_PROG): LIBS += $(SDL_LIBS) $(COCOA_LIBS) $(CURSES_LIBS) $(BRLAPI_LIBS) $(VDE_LIBS)
$(QEMU_PROG): $(OBJS) ../libqemu_common.a libqemu.a
@@ -53,11 +53,11 @@ index f33f762..d1eb876 100644
endif # !CONFIG_USER_ONLY
-diff --git a/hw/pixel_ops.h b/hw/pixel_ops.h
-index d390adf..9100b5c 100644
---- a/hw/pixel_ops.h
-+++ b/hw/pixel_ops.h
-@@ -4,6 +4,12 @@ static inline unsigned int rgb_to_pixel8(unsigned int r, unsigned int g,
+Index: git/hw/pixel_ops.h
+===================================================================
+--- git.orig/hw/pixel_ops.h 2009-12-02 13:13:56.000000000 +0000
++++ git/hw/pixel_ops.h 2010-01-14 15:55:40.000000000 +0000
+@@ -4,6 +4,12 @@
return ((r >> 5) << 5) | ((g >> 5) << 2) | (b >> 6);
}
@@ -70,11 +70,11 @@ index d390adf..9100b5c 100644
static inline unsigned int rgb_to_pixel15(unsigned int r, unsigned int g,
unsigned int b)
{
-diff --git a/hw/vmware_vga.c b/hw/vmware_vga.c
-index d1cba28..c918afb 100644
---- a/hw/vmware_vga.c
-+++ b/hw/vmware_vga.c
-@@ -484,6 +484,8 @@ static inline void vmsvga_cursor_define(struct vmsvga_state_s *s,
+Index: git/hw/vmware_vga.c
+===================================================================
+--- git.orig/hw/vmware_vga.c 2009-12-02 13:13:56.000000000 +0000
++++ git/hw/vmware_vga.c 2010-01-14 15:55:40.000000000 +0000
+@@ -484,6 +484,8 @@
#define CMD(f) le32_to_cpu(s->cmd->f)
@@ -83,7 +83,7 @@ index d1cba28..c918afb 100644
static inline int vmsvga_fifo_empty(struct vmsvga_state_s *s)
{
if (!s->config || !s->enable)
-@@ -493,11 +495,18 @@ static inline int vmsvga_fifo_empty(struct vmsvga_state_s *s)
+@@ -493,11 +495,18 @@
static inline uint32_t vmsvga_fifo_read_raw(struct vmsvga_state_s *s)
{
@@ -106,7 +106,7 @@ index d1cba28..c918afb 100644
}
static inline uint32_t vmsvga_fifo_read(struct vmsvga_state_s *s)
-@@ -507,12 +516,12 @@ static inline uint32_t vmsvga_fifo_read(struct vmsvga_state_s *s)
+@@ -507,12 +516,12 @@
static void vmsvga_fifo_run(struct vmsvga_state_s *s)
{
@@ -121,7 +121,7 @@ index d1cba28..c918afb 100644
case SVGA_CMD_UPDATE:
case SVGA_CMD_UPDATE_VERBOSE:
x = vmsvga_fifo_read(s);
-@@ -612,7 +621,7 @@ static void vmsvga_fifo_run(struct vmsvga_state_s *s)
+@@ -612,7 +621,7 @@
while (args --)
vmsvga_fifo_read(s);
printf("%s: Unknown command 0x%02x in SVGA command FIFO\n",
@@ -130,7 +130,7 @@ index d1cba28..c918afb 100644
break;
}
-@@ -914,8 +923,9 @@ static void vmsvga_reset(struct vmsvga_state_s *s)
+@@ -914,8 +923,9 @@
s->width = -1;
s->height = -1;
s->svgaid = SVGA_ID;
@@ -141,7 +141,7 @@ index d1cba28..c918afb 100644
s->cursor.on = 0;
s->redraw_fifo_first = 0;
s->redraw_fifo_last = 0;
-@@ -1140,6 +1150,12 @@ static void vmsvga_init(struct vmsvga_state_s *s,
+@@ -1140,6 +1150,12 @@
/* XXX: use optimized standard vga accesses */
cpu_register_physical_memory(VBE_DISPI_LFB_PHYSICAL_ADDRESS,
vga_ram_size, vga_ram_offset);
@@ -154,11 +154,11 @@ index d1cba28..c918afb 100644
#endif
}
-diff --git a/kqemu.c b/kqemu.c
-index 25f4ea7..09c761a 100644
---- a/kqemu.c
-+++ b/kqemu.c
-@@ -93,6 +93,8 @@ uint8_t *modified_ram_pages_table;
+Index: git/kqemu.c
+===================================================================
+--- git.orig/kqemu.c 2009-12-02 13:13:56.000000000 +0000
++++ git/kqemu.c 2010-01-14 15:55:40.000000000 +0000
+@@ -93,6 +93,8 @@
int qpi_io_memory;
uint32_t kqemu_comm_base; /* physical address of the QPI communication page */
@@ -167,7 +167,7 @@ index 25f4ea7..09c761a 100644
#define cpuid(index, eax, ebx, ecx, edx) \
asm volatile ("cpuid" \
: "=a" (eax), "=b" (ebx), "=c" (ecx), "=d" (edx) \
-@@ -860,6 +862,22 @@ int kqemu_cpu_exec(CPUState *env)
+@@ -860,6 +862,22 @@
else
env->hflags &= ~HF_OSFXSR_MASK;
@@ -190,11 +190,11 @@ index 25f4ea7..09c761a 100644
LOG_INT("kqemu: kqemu_cpu_exec: ret=0x%x\n", ret);
if (ret == KQEMU_RET_SYSCALL) {
/* syscall instruction */
-diff --git a/qemu-char.c b/qemu-char.c
-index 64d41d0..424ea9b 100644
---- a/qemu-char.c
-+++ b/qemu-char.c
-@@ -2112,6 +2112,69 @@ static CharDriverState *qemu_chr_open_tcp(const char *host_str,
+Index: git/qemu-char.c
+===================================================================
+--- git.orig/qemu-char.c 2009-12-02 13:13:56.000000000 +0000
++++ git/qemu-char.c 2010-01-14 15:55:40.000000000 +0000
+@@ -2112,6 +2112,69 @@
return NULL;
}
@@ -264,7 +264,7 @@ index 64d41d0..424ea9b 100644
CharDriverState *qemu_chr_open(const char *label, const char *filename, void (*init)(struct CharDriverState *s))
{
const char *p;
-@@ -2192,6 +2255,9 @@ CharDriverState *qemu_chr_open(const char *label, const char *filename, void (*i
+@@ -2192,6 +2255,9 @@
chr = chr_baum_init();
} else
#endif
@@ -274,11 +274,11 @@ index 64d41d0..424ea9b 100644
{
chr = NULL;
}
-diff --git a/sdl.c b/sdl.c
-index 74f084c..b78f754 100644
---- a/sdl.c
-+++ b/sdl.c
-@@ -54,6 +54,8 @@ static int guest_cursor = 0;
+Index: git/sdl.c
+===================================================================
+--- git.orig/sdl.c 2009-12-02 13:13:56.000000000 +0000
++++ git/sdl.c 2010-01-14 15:55:40.000000000 +0000
+@@ -54,6 +54,8 @@
static int guest_x, guest_y;
static SDL_Cursor *guest_sprite = 0;
@@ -287,7 +287,7 @@ index 74f084c..b78f754 100644
static void sdl_update(DisplayState *ds, int x, int y, int w, int h)
{
SDL_Rect rec;
-@@ -85,7 +87,9 @@ static void sdl_setdata(DisplayState *ds)
+@@ -85,7 +87,9 @@
static void sdl_resize(DisplayState *ds)
{
@@ -297,7 +297,7 @@ index 74f084c..b78f754 100644
// printf("resizing to %d %d\n", w, h);
-@@ -104,6 +108,13 @@ static void sdl_resize(DisplayState *ds)
+@@ -104,6 +108,13 @@
}
sdl_setdata(ds);
@@ -311,7 +311,7 @@ index 74f084c..b78f754 100644
}
/* generic keyboard conversion */
-@@ -320,7 +331,7 @@ static void sdl_show_cursor(void)
+@@ -323,7 +334,7 @@
if (!kbd_mouse_is_absolute()) {
SDL_ShowCursor(1);
@@ -320,7 +320,7 @@ index 74f084c..b78f754 100644
(gui_grab || kbd_mouse_is_absolute() || absolute_enabled))
SDL_SetCursor(guest_sprite);
else
-@@ -331,7 +342,8 @@ static void sdl_show_cursor(void)
+@@ -334,7 +345,8 @@
static void sdl_grab_start(void)
{
if (guest_cursor) {
@@ -330,7 +330,7 @@ index 74f084c..b78f754 100644
if (!kbd_mouse_is_absolute() && !absolute_enabled)
SDL_WarpMouse(guest_x, guest_y);
} else
-@@ -372,8 +384,8 @@ static void sdl_send_mouse_event(int dx, int dy, int dz, int x, int y, int state
+@@ -375,8 +387,8 @@
absolute_enabled = 1;
}
@@ -341,7 +341,7 @@ index 74f084c..b78f754 100644
} else if (absolute_enabled) {
sdl_show_cursor();
absolute_enabled = 0;
-@@ -603,7 +615,8 @@ static void sdl_mouse_warp(int x, int y, int on)
+@@ -606,7 +618,8 @@
if (!guest_cursor)
sdl_show_cursor();
if (gui_grab || kbd_mouse_is_absolute() || absolute_enabled) {
@@ -351,7 +351,7 @@ index 74f084c..b78f754 100644
if (!kbd_mouse_is_absolute() && !absolute_enabled)
SDL_WarpMouse(x, y);
}
-@@ -628,6 +641,10 @@ static void sdl_mouse_define(int width, int height, int bpp,
+@@ -631,6 +644,10 @@
line = image;
for (x = 0; x < width; x ++, dst ++) {
switch (bpp) {
@@ -362,7 +362,7 @@ index 74f084c..b78f754 100644
case 24:
src = *(line ++); src |= *(line ++); src |= *(line ++);
break;
-@@ -654,7 +671,7 @@ static void sdl_mouse_define(int width, int height, int bpp,
+@@ -657,7 +674,7 @@
}
guest_sprite = SDL_CreateCursor(sprite, mask, width, height, hot_x, hot_y);
@@ -371,7 +371,7 @@ index 74f084c..b78f754 100644
(gui_grab || kbd_mouse_is_absolute() || absolute_enabled))
SDL_SetCursor(guest_sprite);
}
-@@ -670,6 +687,7 @@ void sdl_display_init(DisplayState *ds, int full_screen, int no_frame)
+@@ -673,6 +690,7 @@
{
int flags;
uint8_t data = 0;
@@ -379,7 +379,7 @@ index 74f084c..b78f754 100644
#if defined(__APPLE__)
/* always use generic keymaps */
-@@ -691,6 +709,12 @@ void sdl_display_init(DisplayState *ds, int full_screen, int no_frame)
+@@ -694,6 +712,12 @@
exit(1);
}
@@ -392,7 +392,7 @@ index 74f084c..b78f754 100644
dcl = qemu_mallocz(sizeof(DisplayChangeListener));
dcl->dpy_update = sdl_update;
dcl->dpy_resize = sdl_resize;
-@@ -714,4 +738,9 @@ void sdl_display_init(DisplayState *ds, int full_screen, int no_frame)
+@@ -717,4 +741,9 @@
gui_fullscreen_initial_grab = 1;
sdl_grab_start();
}
@@ -402,10 +402,10 @@ index 74f084c..b78f754 100644
+ opengl_exec_set_parent_window(info.info.x11.display,
+ info.info.x11.window);
}
-diff --git a/slirp/ctl.h b/slirp/ctl.h
-index 4a8576d..201ae4b 100644
---- a/slirp/ctl.h
-+++ b/slirp/ctl.h
+Index: git/slirp/ctl.h
+===================================================================
+--- git.orig/slirp/ctl.h 2009-12-02 13:13:56.000000000 +0000
++++ git/slirp/ctl.h 2010-01-14 15:55:40.000000000 +0000
@@ -2,6 +2,7 @@
#define CTL_EXEC 1
#define CTL_ALIAS 2
@@ -414,10 +414,10 @@ index 4a8576d..201ae4b 100644
#define CTL_SPECIAL "10.0.2.0"
#define CTL_LOCAL "10.0.2.15"
-diff --git a/slirp/udp.c b/slirp/udp.c
-index 8d3bdd2..e5f40cc 100644
---- a/slirp/udp.c
-+++ b/slirp/udp.c
+Index: git/slirp/udp.c
+===================================================================
+--- git.orig/slirp/udp.c 2009-12-02 13:13:56.000000000 +0000
++++ git/slirp/udp.c 2010-01-14 15:55:40.000000000 +0000
@@ -40,6 +40,7 @@
#include <slirp.h>
@@ -426,7 +426,7 @@ index 8d3bdd2..e5f40cc 100644
#ifdef LOG_ENABLED
struct udpstat udpstat;
-@@ -153,6 +154,11 @@ udp_input(m, iphlen)
+@@ -153,6 +154,11 @@
goto bad;
}
@@ -438,11 +438,11 @@ index 8d3bdd2..e5f40cc 100644
if (slirp_restrict)
goto bad;
-diff --git a/sysemu.h b/sysemu.h
-index 57217c1..f0a48cd 100644
---- a/sysemu.h
-+++ b/sysemu.h
-@@ -96,6 +96,7 @@ extern int graphic_rotate;
+Index: git/sysemu.h
+===================================================================
+--- git.orig/sysemu.h 2009-12-02 13:13:56.000000000 +0000
++++ git/sysemu.h 2010-01-14 15:55:40.000000000 +0000
+@@ -96,6 +96,7 @@
extern int no_quit;
extern int semihosting_enabled;
extern int old_param;
@@ -450,11 +450,10 @@ index 57217c1..f0a48cd 100644
extern const char *bootp_filename;
#ifdef USE_KQEMU
-diff --git a/target-i386/beginend_funcs.sh b/target-i386/beginend_funcs.sh
-new file mode 100755
-index 0000000..bdd7684
---- /dev/null
-+++ b/target-i386/beginend_funcs.sh
+Index: git/target-i386/beginend_funcs.sh
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/beginend_funcs.sh 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,23 @@
+#! /bin/sh
+# Copyright 2008 (C) Intel Corporation
@@ -479,11 +478,10 @@ index 0000000..bdd7684
+echo -e MAGIC_MACRO\(glCallList\)\\n
+echo -e MAGIC_MACRO\(glCallLists\)\\n
+echo -e MAGIC_MACRO\(glEdgeFlag{,v}\)\\n
-diff --git a/target-i386/ghash.c b/target-i386/ghash.c
-new file mode 100644
-index 0000000..1f0c380
---- /dev/null
-+++ b/target-i386/ghash.c
+Index: git/target-i386/ghash.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/ghash.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,347 @@
+/* This is a modified and simplified version of original ghash.c */
+
@@ -832,11 +830,10 @@ index 0000000..1f0c380
+ hash_node = next;
+ }
+}
-diff --git a/target-i386/ghash.h b/target-i386/ghash.h
-new file mode 100644
-index 0000000..7f34436
---- /dev/null
-+++ b/target-i386/ghash.h
+Index: git/target-i386/ghash.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/ghash.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,59 @@
+/* This is a modified and simplified version of original ghash.h */
+
@@ -897,11 +894,10 @@ index 0000000..7f34436
+
+#endif /* __SIMPLE_HASH_H__ */
+
-diff --git a/target-i386/gl_func_perso.h b/target-i386/gl_func_perso.h
-new file mode 100644
-index 0000000..401c0a8
---- /dev/null
-+++ b/target-i386/gl_func_perso.h
+Index: git/target-i386/gl_func_perso.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/gl_func_perso.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,135 @@
+/*
+ * Hand-implemented GL/GLX API
@@ -1038,11 +1034,11 @@ index 0000000..401c0a8
+MAGIC_MACRO(_glGetSelectBuffer_fake),
+MAGIC_MACRO(_glFeedbackBuffer_fake),
+MAGIC_MACRO(_glGetFeedbackBuffer_fake),
-diff --git a/target-i386/helper.c b/target-i386/helper.c
-index e714994..7354220 100644
---- a/target-i386/helper.c
-+++ b/target-i386/helper.c
-@@ -1320,7 +1320,7 @@ target_phys_addr_t cpu_get_phys_page_debug(CPUState *env, target_ulong addr)
+Index: git/target-i386/helper.c
+===================================================================
+--- git.orig/target-i386/helper.c 2009-12-02 13:13:56.000000000 +0000
++++ git/target-i386/helper.c 2010-01-14 15:55:40.000000000 +0000
+@@ -1326,7 +1326,7 @@
}
page_offset = (addr & TARGET_PAGE_MASK) & (page_size - 1);
@@ -1051,23 +1047,22 @@ index e714994..7354220 100644
return paddr;
}
-diff --git a/target-i386/helper.h b/target-i386/helper.h
-index 0c36783..b247b35 100644
---- a/target-i386/helper.h
-+++ b/target-i386/helper.h
-@@ -214,4 +214,6 @@ DEF_HELPER_2(rclq, tl, tl, tl)
+Index: git/target-i386/helper.h
+===================================================================
+--- git.orig/target-i386/helper.h 2009-12-02 13:13:56.000000000 +0000
++++ git/target-i386/helper.h 2010-01-14 15:55:40.000000000 +0000
+@@ -214,4 +214,6 @@
DEF_HELPER_2(rcrq, tl, tl, tl)
#endif
+DEF_HELPER_0(opengl, void)
+
#include "def-helper.h"
-diff --git a/target-i386/helper_opengl.c b/target-i386/helper_opengl.c
-new file mode 100644
-index 0000000..f83d02b
---- /dev/null
-+++ b/target-i386/helper_opengl.c
-@@ -0,0 +1,1205 @@
+Index: git/target-i386/helper_opengl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/helper_opengl.c 2010-01-14 16:36:59.000000000 +0000
+@@ -0,0 +1,1207 @@
+/*
+ * Host-side implementation of GL/GLX API
+ *
@@ -2041,6 +2036,8 @@ index 0000000..f83d02b
+ target_ret_string, in_args, in_args_size);
+}
+
++#define env first_cpu
++
+void helper_opengl(void)
+{
+ doing_opengl = 1;
@@ -2273,11 +2270,11 @@ index 0000000..f83d02b
+ io_register();
+}
+#endif
-diff --git a/target-i386/kvm.c b/target-i386/kvm.c
-index eb61598..5c6fbae 100644
---- a/target-i386/kvm.c
-+++ b/target-i386/kvm.c
-@@ -480,7 +480,7 @@ static int kvm_get_fpu(CPUState *env)
+Index: git/target-i386/kvm.c
+===================================================================
+--- git.orig/target-i386/kvm.c 2009-12-02 13:13:56.000000000 +0000
++++ git/target-i386/kvm.c 2010-01-14 15:55:40.000000000 +0000
+@@ -480,7 +480,7 @@
return 0;
}
@@ -2286,11 +2283,10 @@ index eb61598..5c6fbae 100644
{
struct kvm_sregs sregs;
uint32_t hflags;
-diff --git a/target-i386/mesa_enums.c b/target-i386/mesa_enums.c
-new file mode 100644
-index 0000000..61a540c
---- /dev/null
-+++ b/target-i386/mesa_enums.c
+Index: git/target-i386/mesa_enums.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_enums.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,4890 @@
+/* DO NOT EDIT - This file generated automatically by gl_enums.py (from Mesa) script */
+
@@ -7182,11 +7178,10 @@ index 0000000..61a540c
+}
+
+
-diff --git a/target-i386/mesa_get.c b/target-i386/mesa_get.c
-new file mode 100644
-index 0000000..3b4c9aa
---- /dev/null
-+++ b/target-i386/mesa_get.c
+Index: git/target-i386/mesa_get.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_get.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,5563 @@
+
+/***
@@ -12751,11 +12746,10 @@ index 0000000..3b4c9aa
+ params[i] = (GLdouble) values[i];
+}
+
-diff --git a/target-i386/mesa_gl.h b/target-i386/mesa_gl.h
-new file mode 100644
-index 0000000..dc2047c
---- /dev/null
-+++ b/target-i386/mesa_gl.h
+Index: git/target-i386/mesa_gl.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_gl.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,2251 @@
+/*
+ * Mesa 3-D graphics library
@@ -15008,11 +15002,10 @@ index 0000000..dc2047c
+#endif
+
+#endif /* __gl_h_ */
-diff --git a/target-i386/mesa_glext.h b/target-i386/mesa_glext.h
-new file mode 100644
-index 0000000..f8cf2d2
---- /dev/null
-+++ b/target-i386/mesa_glext.h
+Index: git/target-i386/mesa_glext.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_glext.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,7279 @@
+#ifndef __glext_h_
+#define __glext_h_
@@ -22293,11 +22286,10 @@ index 0000000..f8cf2d2
+
+/* ERO */
+GLAPI void GLAPIENTRY fake_gluBuild2DMipmaps (GLenum target, GLint internalFormat, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *data);
-diff --git a/target-i386/mesa_glu.h b/target-i386/mesa_glu.h
-new file mode 100644
-index 0000000..f1a704b
---- /dev/null
-+++ b/target-i386/mesa_glu.h
+Index: git/target-i386/mesa_glu.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_glu.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,354 @@
+/*
+** License Applicability. Except to the extent portions of this file are
@@ -22653,11 +22645,10 @@ index 0000000..f1a704b
+#endif
+
+#endif /* __glu_h__ */
-diff --git a/target-i386/mesa_glx.h b/target-i386/mesa_glx.h
-new file mode 100644
-index 0000000..2930461
---- /dev/null
-+++ b/target-i386/mesa_glx.h
+Index: git/target-i386/mesa_glx.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_glx.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,510 @@
+/*
+ * Mesa 3-D graphics library
@@ -23169,11 +23160,10 @@ index 0000000..2930461
+#endif
+
+#endif
-diff --git a/target-i386/mesa_glxext.h b/target-i386/mesa_glxext.h
-new file mode 100644
-index 0000000..0f66df6
---- /dev/null
-+++ b/target-i386/mesa_glxext.h
+Index: git/target-i386/mesa_glxext.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_glxext.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,785 @@
+#ifndef __glxext_h_
+#define __glxext_h_
@@ -23960,11 +23950,10 @@ index 0000000..0f66df6
+#endif
+
+#endif
-diff --git a/target-i386/mesa_mipmap.c b/target-i386/mesa_mipmap.c
-new file mode 100644
-index 0000000..f623ea1
---- /dev/null
-+++ b/target-i386/mesa_mipmap.c
+Index: git/target-i386/mesa_mipmap.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/mesa_mipmap.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,824 @@
+
+/*
@@ -24790,11 +24779,10 @@ index 0000000..f623ea1
+
+ return retval;
+}
-diff --git a/target-i386/opengl_exec.c b/target-i386/opengl_exec.c
-new file mode 100644
-index 0000000..4a69b9b
---- /dev/null
-+++ b/target-i386/opengl_exec.c
+Index: git/target-i386/opengl_exec.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/opengl_exec.c 2010-01-14 16:34:53.000000000 +0000
@@ -0,0 +1,3931 @@
+/*
+ * Host-side implementation of GL/GLX API
@@ -28727,11 +28715,10 @@ index 0000000..4a69b9b
+
+ return ret_int;
+}
-diff --git a/target-i386/opengl_func.h b/target-i386/opengl_func.h
-new file mode 100644
-index 0000000..d1b50fd
---- /dev/null
-+++ b/target-i386/opengl_func.h
+Index: git/target-i386/opengl_func.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/opengl_func.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,1108 @@
+/*
+ * Main header for both host and guest sides
@@ -29841,11 +29828,10 @@ index 0000000..d1b50fd
+#error Unsupported ABI
+#endif
+#endif
-diff --git a/target-i386/opengl_player.c b/target-i386/opengl_player.c
-new file mode 100644
-index 0000000..f071b7f
---- /dev/null
-+++ b/target-i386/opengl_player.c
+Index: git/target-i386/opengl_player.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/opengl_player.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,1461 @@
+/*
+ * Plays a sequence of OpenGL calls recorded either under qemu or with opengl_server
@@ -31308,11 +31294,10 @@ index 0000000..f071b7f
+ }
+ return 0;
+}
-diff --git a/target-i386/opengl_server.c b/target-i386/opengl_server.c
-new file mode 100644
-index 0000000..80060ba
---- /dev/null
-+++ b/target-i386/opengl_server.c
+Index: git/target-i386/opengl_server.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/opengl_server.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,826 @@
+/*
+ * TCP/IP OpenGL server
@@ -32140,11 +32125,10 @@ index 0000000..80060ba
+
+ return 0;
+}
-diff --git a/target-i386/opengl_utils.h b/target-i386/opengl_utils.h
-new file mode 100644
-index 0000000..01077ff
---- /dev/null
-+++ b/target-i386/opengl_utils.h
+Index: git/target-i386/opengl_utils.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/opengl_utils.h 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,453 @@
+/*
+ * Functions used by host & client sides
@@ -32599,11 +32583,10 @@ index 0000000..01077ff
+}
+
+#endif
-diff --git a/target-i386/parse_gl_h.c b/target-i386/parse_gl_h.c
-new file mode 100644
-index 0000000..f1e93ec
---- /dev/null
-+++ b/target-i386/parse_gl_h.c
+Index: git/target-i386/parse_gl_h.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/parse_gl_h.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,1496 @@
+/*
+ * Parse gl.h et glx.h to auto-generate source code
@@ -34101,11 +34084,10 @@ index 0000000..f1e93ec
+
+ return 0;
+}
-diff --git a/target-i386/parse_mesa_get_c.c b/target-i386/parse_mesa_get_c.c
-new file mode 100644
-index 0000000..b214358
---- /dev/null
-+++ b/target-i386/parse_mesa_get_c.c
+Index: git/target-i386/parse_mesa_get_c.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-i386/parse_mesa_get_c.c 2010-01-14 15:55:40.000000000 +0000
@@ -0,0 +1,225 @@
+/*
+ * Parse the "get.c" from mesa source tree to generate "glgetv_cst.h"
@@ -34332,11 +34314,11 @@ index 0000000..b214358
+ fclose(outf);
+ return 0;
+}
-diff --git a/target-i386/translate.c b/target-i386/translate.c
-index 4b894fd..10920a7 100644
---- a/target-i386/translate.c
-+++ b/target-i386/translate.c
-@@ -741,6 +741,8 @@ static void gen_check_io(DisasContext *s, int ot, target_ulong cur_eip,
+Index: git/target-i386/translate.c
+===================================================================
+--- git.orig/target-i386/translate.c 2009-12-02 13:13:56.000000000 +0000
++++ git/target-i386/translate.c 2010-01-14 15:55:40.000000000 +0000
+@@ -741,6 +741,8 @@
int state_saved;
target_ulong next_eip;
@@ -34345,7 +34327,7 @@ index 4b894fd..10920a7 100644
state_saved = 0;
if (s->pe && (s->cpl > s->iopl || s->vm86)) {
if (s->cc_op != CC_OP_DYNAMIC)
-@@ -2592,11 +2594,18 @@ static void gen_exception(DisasContext *s, int trapno, target_ulong cur_eip)
+@@ -2592,11 +2594,18 @@
s->is_jmp = 3;
}
@@ -34364,11 +34346,11 @@ index 4b894fd..10920a7 100644
if (s->cc_op != CC_OP_DYNAMIC)
gen_op_set_cc_op(s->cc_op);
gen_jmp_im(cur_eip);
-diff --git a/vl.c b/vl.c
-index 56623fb..095da54 100644
---- a/vl.c
-+++ b/vl.c
-@@ -245,6 +245,7 @@ int semihosting_enabled = 0;
+Index: git/vl.c
+===================================================================
+--- git.orig/vl.c 2009-12-02 13:13:56.000000000 +0000
++++ git/vl.c 2010-01-14 15:55:40.000000000 +0000
+@@ -245,6 +245,7 @@
#ifdef TARGET_ARM
int old_param = 0;
#endif
@@ -34376,7 +34358,7 @@ index 56623fb..095da54 100644
const char *qemu_name;
int alt_grab = 0;
#if defined(TARGET_SPARC) || defined(TARGET_PPC)
-@@ -253,6 +254,7 @@ const char *prom_envs[MAX_PROM_ENVS];
+@@ -253,6 +254,7 @@
#endif
int nb_drives_opt;
struct drive_opt drives_opt[MAX_DRIVES];
@@ -34384,7 +34366,7 @@ index 56623fb..095da54 100644
static CPUState *cur_cpu;
static CPUState *next_cpu;
-@@ -4208,12 +4210,14 @@ enum {
+@@ -4208,12 +4210,14 @@
QEMU_OPTION_clock,
QEMU_OPTION_localtime,
QEMU_OPTION_startdate,
@@ -34399,7 +34381,7 @@ index 56623fb..095da54 100644
QEMU_OPTION_tb_size,
QEMU_OPTION_incoming,
QEMU_OPTION_chroot,
-@@ -4344,6 +4348,8 @@ static const QEMUOption qemu_options[] = {
+@@ -4344,6 +4348,8 @@
#if defined(TARGET_ARM)
{ "old-param", 0, QEMU_OPTION_old_param },
#endif
@@ -34408,7 +34390,7 @@ index 56623fb..095da54 100644
{ "tb-size", HAS_ARG, QEMU_OPTION_tb_size },
{ "incoming", HAS_ARG, QEMU_OPTION_incoming },
{ "chroot", HAS_ARG, QEMU_OPTION_chroot },
-@@ -4496,22 +4502,17 @@ static void select_vgahw (const char *p)
+@@ -4496,22 +4502,17 @@
{
const char *opts;
@@ -34435,7 +34417,7 @@ index 56623fb..095da54 100644
} else {
invalid_vga:
fprintf(stderr, "Unknown vga type: %s\n", p);
-@@ -5220,6 +5221,9 @@ int main(int argc, char **argv, char **envp)
+@@ -5220,6 +5221,9 @@
old_param = 1;
break;
#endif
@@ -34445,7 +34427,7 @@ index 56623fb..095da54 100644
case QEMU_OPTION_clock:
configure_alarms(optarg);
break;
-@@ -5261,6 +5265,11 @@ int main(int argc, char **argv, char **envp)
+@@ -5261,6 +5265,11 @@
}
}
break;
@@ -34457,7 +34439,7 @@ index 56623fb..095da54 100644
case QEMU_OPTION_tb_size:
tb_size = strtol(optarg, NULL, 0);
if (tb_size < 0)
-@@ -5545,6 +5554,17 @@ int main(int argc, char **argv, char **envp)
+@@ -5545,6 +5554,17 @@
exit(1);
}
}
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
index 057543530..c8383f4af 100644
--- a/meta/packages/qemu/qemu_git.bb
+++ b/meta/packages/qemu/qemu_git.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
PV = "0.10.6+git${SRCREV}"
-PR = "r0"
+PR = "r1"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"