summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-09-30 11:40:52 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-09-30 11:40:52 +0000
commit5ef0510474004eeb2ae8a99b64e2febb1920e077 (patch)
tree689b3248f22bda1311b4d1b90d9fc27bc05d9d60
parentde39802df220e7356e27a1ae02d058913f4f95e6 (diff)
downloadopenembedded-core-5ef0510474004eeb2ae8a99b64e2febb1920e077.tar.gz
openembedded-core-5ef0510474004eeb2ae8a99b64e2febb1920e077.tar.bz2
openembedded-core-5ef0510474004eeb2ae8a99b64e2febb1920e077.tar.xz
openembedded-core-5ef0510474004eeb2ae8a99b64e2febb1920e077.zip
git: depend on native perl and use it
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5335 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/git/git-native_1.5.4.4.bb4
-rw-r--r--meta/packages/git/git.inc3
2 files changed, 4 insertions, 3 deletions
diff --git a/meta/packages/git/git-native_1.5.4.4.bb b/meta/packages/git/git-native_1.5.4.4.bb
index 935c773c1..69f6f014c 100644
--- a/meta/packages/git/git-native_1.5.4.4.bb
+++ b/meta/packages/git/git-native_1.5.4.4.bb
@@ -1,4 +1,4 @@
require git.inc
inherit native
-DEPENDS = "openssl-native curl-native zlib-native expat-native"
-PR = "r1"
+DEPENDS += "openssl-native curl-native zlib-native expat-native"
+PR = "r2"
diff --git a/meta/packages/git/git.inc b/meta/packages/git/git.inc
index 7115d44b3..3e8781158 100644
--- a/meta/packages/git/git.inc
+++ b/meta/packages/git/git.inc
@@ -1,12 +1,13 @@
DESCRIPTION = "The git revision control system used by the Linux kernel developers"
SECTION = "console/utils"
LICENSE = "GPL"
+DEPENDS = "perl-native"
SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
file://autotools.patch;patch=1"
S = "${WORKDIR}/git-${PV}"
-EXTRA_OEMAKE = "NO_TCLTL=1"
+EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl --without-tcltk"
inherit autotools