summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-29 13:39:28 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-30 14:50:31 +0100
commit5fba534b15baa3778bbce2952ac7664bcda4e73c (patch)
tree0de9b68e3a37292a19516aa9c1c772a63a009f74
parent1acae1c5008b0267ed93725a9181091a338f5df3 (diff)
downloadopenembedded-core-5fba534b15baa3778bbce2952ac7664bcda4e73c.tar.gz
openembedded-core-5fba534b15baa3778bbce2952ac7664bcda4e73c.tar.bz2
openembedded-core-5fba534b15baa3778bbce2952ac7664bcda4e73c.tar.xz
openembedded-core-5fba534b15baa3778bbce2952ac7664bcda4e73c.zip
dhcp: fix $PATH environment for dhclient-script
CLIENT_PATH is the only environment variable of dhclient-script, change it to include major run path, [BUGFIX#132] Signed-off-by: Qing He <qing.he@intel.com>
-rw-r--r--meta/packages/dhcp/dhcp-4.1.1-P1/fix-client-path.patch21
-rw-r--r--meta/packages/dhcp/dhcp_4.1.1-P1.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/meta/packages/dhcp/dhcp-4.1.1-P1/fix-client-path.patch b/meta/packages/dhcp/dhcp-4.1.1-P1/fix-client-path.patch
new file mode 100644
index 000000000..f6a7be1d8
--- /dev/null
+++ b/meta/packages/dhcp/dhcp-4.1.1-P1/fix-client-path.patch
@@ -0,0 +1,21 @@
+CLIENT_PATH is the only environment when executing dhclient-script,
+without this patch, dhclient-script won't run properly because it
+invokes ifconfig and route
+
+7/28/2010 - qhe
+
+diff -ru dhcp-4.1.1-P1.orig//client/Makefile.am dhcp-4.1.1-P1/client/Makefile.am
+--- dhcp-4.1.1-P1.orig//client/Makefile.am 2010-07-29 13:20:05.000000000 +0800
++++ dhcp-4.1.1-P1/client/Makefile.am 2010-07-29 13:28:14.000000000 +0800
+@@ -10,9 +10,9 @@
+ EXTRA_DIST = $(man_MANS)
+
+ dhclient.o: dhclient.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):$(base_sbindir):$(bindir):$(base_bindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhclient.c
+
+ dhc6.o: dhc6.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):$(base_sbindir):$(bindir):$(base_bindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
diff --git a/meta/packages/dhcp/dhcp_4.1.1-P1.bb b/meta/packages/dhcp/dhcp_4.1.1-P1.bb
index c7025f850..e9759de56 100644
--- a/meta/packages/dhcp/dhcp_4.1.1-P1.bb
+++ b/meta/packages/dhcp/dhcp_4.1.1-P1.bb
@@ -1,6 +1,7 @@
require dhcp4.inc
-PR = "r0"
+PR = "r1"
SRC_URI += "file://fixincludes.patch \
- file://dhcp-3.0.3-dhclient-dbus.patch;striplevel=0"
+ file://dhcp-3.0.3-dhclient-dbus.patch;striplevel=0 \
+ file://fix-client-path.patch"