summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-03 18:33:03 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-03 18:33:03 +0000
commit66b6014139d4e4c0b0c2e21c6a08cc31c31652b0 (patch)
tree03813b44a50e84ff3998b5610cbc5350437d4ac1
parent8bc4105ddff851fc0e2c716d677b52236f6c3209 (diff)
downloadopenembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.tar.gz
openembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.tar.bz2
openembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.tar.xz
openembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.zip
fakeroot: Clean up and convert to BBCLASSEXTEND
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.9.4.bb21
-rw-r--r--meta/packages/fakeroot/fakeroot/configure-libtool.patch (renamed from meta/packages/fakeroot/files/configure-libtool.patch)0
-rw-r--r--meta/packages/fakeroot/fakeroot_1.9.4.bb15
-rw-r--r--meta/packages/fakeroot/files/fix-prefix.patch18
4 files changed, 11 insertions, 43 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.9.4.bb b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
deleted file mode 100644
index 77d6f5865..000000000
--- a/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-require fakeroot_${PV}.bb
-
-RDEPENDS="util-linux-native"
-
-SRC_URI += "file://fix-prefix.patch;patch=1 "
-S = "${WORKDIR}/fakeroot-${PV}"
-
-inherit native
-
-EXTRA_OECONF = " --program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
- if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
- bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-do_stage_append () {
- oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
-
diff --git a/meta/packages/fakeroot/files/configure-libtool.patch b/meta/packages/fakeroot/fakeroot/configure-libtool.patch
index 8830328eb..8830328eb 100644
--- a/meta/packages/fakeroot/files/configure-libtool.patch
+++ b/meta/packages/fakeroot/fakeroot/configure-libtool.patch
diff --git a/meta/packages/fakeroot/fakeroot_1.9.4.bb b/meta/packages/fakeroot/fakeroot_1.9.4.bb
index aaf696d79..04219519e 100644
--- a/meta/packages/fakeroot/fakeroot_1.9.4.bb
+++ b/meta/packages/fakeroot/fakeroot_1.9.4.bb
@@ -4,15 +4,22 @@ SECTION = "base"
LICENSE = "GPL"
# fakeroot needs getopt which is provided by the util-linux package
RDEPENDS = "util-linux"
-PR = "r1"
+PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
file://configure-libtool.patch;patch=1"
-inherit autotools
+inherit autotools_stage
-do_stage() {
+do_stage_append() {
install -d ${STAGING_INCDIR}/fakeroot
install -m 644 *.h ${STAGING_INCDIR}/fakeroot
- autotools_stage_all
}
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
+}
+
+BBCLASSEXTEND = "native" \ No newline at end of file
diff --git a/meta/packages/fakeroot/files/fix-prefix.patch b/meta/packages/fakeroot/files/fix-prefix.patch
deleted file mode 100644
index 3884aca01..000000000
--- a/meta/packages/fakeroot/files/fix-prefix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
-+++ fakeroot-1.2.13/scripts/fakeroot.in
-@@ -15,8 +15,8 @@
- }
-
- # strip /bin/fakeroot to find install prefix
--PREFIX=@prefix@
--BINDIR=@bindir@
-+BINDIR=`dirname $0`
-+PREFIX=`dirname ${BINDIR}`
-
- LIB=lib@fakeroot_transformed@.so.0
- PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot