summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-07 00:02:28 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-07 00:02:28 +0000
commit68e1ac6996910d5f0dd0cc04cdc0c1178eb9c308 (patch)
treeef7656e5b9ab30afeb133c83f82d5bcde490387f
parente3c007f4bbe587250106f2d1e55343e6edeaa657 (diff)
downloadopenembedded-core-68e1ac6996910d5f0dd0cc04cdc0c1178eb9c308.tar.gz
openembedded-core-68e1ac6996910d5f0dd0cc04cdc0c1178eb9c308.tar.bz2
openembedded-core-68e1ac6996910d5f0dd0cc04cdc0c1178eb9c308.tar.xz
openembedded-core-68e1ac6996910d5f0dd0cc04cdc0c1178eb9c308.zip
ohm: Fix configure problems
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3973 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/ohm/ohm/fix_configure.patch39
-rw-r--r--meta/packages/ohm/ohm_git.bb5
2 files changed, 42 insertions, 2 deletions
diff --git a/meta/packages/ohm/ohm/fix_configure.patch b/meta/packages/ohm/ohm/fix_configure.patch
new file mode 100644
index 000000000..e4b774e78
--- /dev/null
+++ b/meta/packages/ohm/ohm/fix_configure.patch
@@ -0,0 +1,39 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2007-12-19 13:43:52.000000000 +0000
++++ git/configure.in 2008-03-06 23:59:57.000000000 +0000
+@@ -201,9 +201,6 @@
+ # Like AC_CHECK_HEADER, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_CHECK_X_HEADER, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_CHECK_HEADER([$1],[$2],[$3],[$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -211,9 +208,6 @@
+ # Like AC_TRY_COMPILE, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_TRY_X_COMPILE, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_TRY_COMPILE([$1], [$2], [$3], [$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -224,14 +218,8 @@
+ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LDFLAGS="$LDFLAGS"
+ # ac_save_LIBS="$LIBS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ # note: $X_CFLAGS includes $x_includes
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+- if test \! -z "$libdir" ; then
+- LDFLAGS="$LDFLAGS -L$libdir"
+- fi
+ # note: $X_LIBS includes $x_libraries
+ LDFLAGS="$LDFLAGS $ALL_X_LIBS"
+ AC_CHECK_LIB([$1], [$2], [$3], [$4], [$5])
diff --git a/meta/packages/ohm/ohm_git.bb b/meta/packages/ohm/ohm_git.bb
index 18dc58de7..2ba78b35a 100644
--- a/meta/packages/ohm/ohm_git.bb
+++ b/meta/packages/ohm/ohm_git.bb
@@ -4,10 +4,11 @@ LICENSE = "LGPL"
DEPENDS = "gtk+ dbus-glib intltool-native hal"
RDEPENDS_${PN} += "udev hal-info"
-SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
+ file://fix_configure.patch;patch=1"
PV = "0.1.2+git-locrev${SRCREV}"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/git"