summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-28 22:53:51 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-28 22:53:51 +0000
commit71c9c36c486e97aa17b569f10bdb22be0d2bb998 (patch)
treed04ce886276041fed1b91371d0acbffa08a48f03
parent3fab5dd14e6fef46d67957d0ec3dc729a4406387 (diff)
downloadopenembedded-core-71c9c36c486e97aa17b569f10bdb22be0d2bb998.tar.gz
openembedded-core-71c9c36c486e97aa17b569f10bdb22be0d2bb998.tar.bz2
openembedded-core-71c9c36c486e97aa17b569f10bdb22be0d2bb998.tar.xz
openembedded-core-71c9c36c486e97aa17b569f10bdb22be0d2bb998.zip
Add gnome-common for eds-dbus
git-svn-id: https://svn.o-hand.com/repos/poky@57 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/gnome/gnome-common/omf.patch13
-rw-r--r--openembedded/packages/gnome/gnome-common_2.4.0.bb28
2 files changed, 41 insertions, 0 deletions
diff --git a/openembedded/packages/gnome/gnome-common/omf.patch b/openembedded/packages/gnome/gnome-common/omf.patch
new file mode 100644
index 000000000..334425e4b
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-common/omf.patch
@@ -0,0 +1,13 @@
+--- gnome-common-2.4.0/doc-build/omf.make 2003-05-24 08:16:25.000000000 -0700
++++ gnome-common-2.4.0.new/doc-build/omf.make 2004-11-15 14:01:12.185155192 -0700
+@@ -43,7 +43,9 @@
+ install-data-hook-omf:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ for file in $(omffile); do \
+- $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ if [ -f $$file.out ]; then \
++ $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ fi; \
+ done
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir) -o $(DESTDIR)$(omf_dest_dir)
+
diff --git a/openembedded/packages/gnome/gnome-common_2.4.0.bb b/openembedded/packages/gnome/gnome-common_2.4.0.bb
new file mode 100644
index 000000000..2991db81c
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-common_2.4.0.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+PR = "r0"
+DESCRIPTION = "Common macros for building GNOME applications"
+inherit gnome
+
+# The omf.make file failed if scrollkeeper doesn't happen to be
+# installed
+
+SRC_URI += "file://omf.patch;patch=1"
+
+EXTRA_AUTORECONF = ""
+DEPENDS = ""
+
+FILES_${PN} += "${datadir}/aclocal"
+FILES_${PN}-dev = ""
+
+do_stage () {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ make DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_DIR}/${BUILD_SYS}/bin
+ install -d ${STAGING_DATADIR}/gnome-common
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common
+ cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ rm -rf ${STAGE_TEMP}
+}