summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-19 21:42:36 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-19 21:42:36 +0000
commit76b5863170eebf5ea61fcbf79eb963d4c9092352 (patch)
treeae457347a9a0d9ed089eac305d8c61360071a8d7
parent04066bd057c80b72c4472b05e537fa8522f750aa (diff)
downloadopenembedded-core-76b5863170eebf5ea61fcbf79eb963d4c9092352.tar.gz
openembedded-core-76b5863170eebf5ea61fcbf79eb963d4c9092352.tar.bz2
openembedded-core-76b5863170eebf5ea61fcbf79eb963d4c9092352.tar.xz
openembedded-core-76b5863170eebf5ea61fcbf79eb963d4c9092352.zip
psplash: Remove pointless cat calls, promote to .sh initscript
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5083 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rwxr-xr-xmeta/packages/psplash/files/psplash-init5
-rw-r--r--meta/packages/psplash/psplash_svn.bb6
2 files changed, 6 insertions, 5 deletions
diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
index ea370d622..66c85e933 100755
--- a/meta/packages/psplash/files/psplash-init
+++ b/meta/packages/psplash/files/psplash-init
@@ -7,7 +7,8 @@
# Default-Stop:
### END INIT INFO
-for x in $(cat /proc/cmdline); do
+read CMDLINE < /proc/cmdline
+for x in $CMDLINE; do
case $x in
psplash=false)
echo "Boot splashscreen disabled"
@@ -21,7 +22,7 @@ mount tmpfs -t tmpfs $TMPDIR -o,size=40k
rotation=0
if [ -e /etc/rotation ]; then
- rotation=`cat /etc/rotation`
+ read rotation < /etc/rotation
fi
/usr/bin/psplash --angle $rotation &
diff --git a/meta/packages/psplash/psplash_svn.bb b/meta/packages/psplash/psplash_svn.bb
index f27839906..d46b051c6 100644
--- a/meta/packages/psplash/psplash_svn.bb
+++ b/meta/packages/psplash/psplash_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-init"
@@ -16,8 +16,8 @@ FILES_${PN} += "/mnt/.psplash"
do_install_prepend() {
install -d ${D}/mnt/.psplash/
install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+ install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
}
-INITSCRIPT_NAME = "psplash"
+INITSCRIPT_NAME = "psplash.sh"
INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."