summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-06-23 10:27:10 +0000
committerRoss Burton <ross@openedhand.com>2008-06-23 10:27:10 +0000
commit7717814038132be599f0df85a5b96a1fa9b3fa28 (patch)
treeab6c71ab6ca94c4b6e2e4ac1468e1543a62f9148
parentf25cb73075ca077a82fa71f91ad0972868709f10 (diff)
downloadopenembedded-core-7717814038132be599f0df85a5b96a1fa9b3fa28.tar.gz
openembedded-core-7717814038132be599f0df85a5b96a1fa9b3fa28.tar.bz2
openembedded-core-7717814038132be599f0df85a5b96a1fa9b3fa28.tar.xz
openembedded-core-7717814038132be599f0df85a5b96a1fa9b3fa28.zip
udev: don't fork so much in mount.sh
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4717 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/udev/files/mount.sh13
-rw-r--r--meta/packages/udev/udev_115.bb2
2 files changed, 8 insertions, 7 deletions
diff --git a/meta/packages/udev/files/mount.sh b/meta/packages/udev/files/mount.sh
index 48c784469..160acbfde 100644
--- a/meta/packages/udev/files/mount.sh
+++ b/meta/packages/udev/files/mount.sh
@@ -1,16 +1,15 @@
#!/bin/sh
#
# Called from udev
-# Attemp to mount any added block devices
-# and remove any removed devices
#
+# Attempt to mount any added block devices and umount any removed devices
+
MOUNT="/bin/mount"
PMOUNT="/usr/bin/pmount"
UMOUNT="/bin/umount"
-name="`basename "$DEVNAME"`"
-for line in `cat /etc/udev/mount.blacklist | grep -v ^#`
+for line in `grep -v ^# /etc/udev/mount.blacklist`
do
if ( echo "$DEVNAME" | grep -q "$line" )
then
@@ -20,6 +19,8 @@ do
done
automount() {
+ name="`basename "$DEVNAME"`"
+
! test -d "/media/$name" && mkdir -p "/media/$name"
if ! $MOUNT -t auto -o sync $DEVNAME "/media/$name"
@@ -50,8 +51,7 @@ if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
fi
# If the device isn't mounted at this point, it isn't configured in fstab
- cat /proc/mounts | awk '{print $1}' | grep -q "^$DEVNAME$" || automount
-
+ grep -q "^$DEVNAME " /proc/mounts || automount
fi
@@ -63,5 +63,6 @@ if [ "$ACTION" = "remove" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
done
# Remove empty directories from auto-mounter
+ name="`basename "$DEVNAME"`"
test -e "/tmp/.automount-$name" && rm_dir "/media/$name"
fi
diff --git a/meta/packages/udev/udev_115.bb b/meta/packages/udev/udev_115.bb
index 0a80af9bd..b688ca88d 100644
--- a/meta/packages/udev/udev_115.bb
+++ b/meta/packages/udev/udev_115.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES_${PN} = "hotplug"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \