summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-05-09 13:42:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-11 17:50:35 +0100
commit8691038efb0aca4a2cd61fce0c53d10092e48b75 (patch)
tree11ad9e2d61e66f840af788f28ef388786d1451b6
parent13fcda4b158ce944d64b22bd5b63ce0f51faad67 (diff)
downloadopenembedded-core-8691038efb0aca4a2cd61fce0c53d10092e48b75.tar.gz
openembedded-core-8691038efb0aca4a2cd61fce0c53d10092e48b75.tar.bz2
openembedded-core-8691038efb0aca4a2cd61fce0c53d10092e48b75.tar.xz
openembedded-core-8691038efb0aca4a2cd61fce0c53d10092e48b75.zip
eglibc: fix build with poky-tiny distro
This fixes bug [YOCTO #2443] The prototype of findidx() has changed, but the code in xregex.c is still using the old prototype. This issue stayed hidden because this code only gets excercised when OPTION_POSIX_REGEXP_GLIBC is disabled in the eglibc configuration. See the patch for further information. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.15/eglibc_fix_findidx_parameters.patch38
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb3
2 files changed, 40 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.15/eglibc_fix_findidx_parameters.patch b/meta/recipes-core/eglibc/eglibc-2.15/eglibc_fix_findidx_parameters.patch
new file mode 100644
index 000000000..bbf460550
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.15/eglibc_fix_findidx_parameters.patch
@@ -0,0 +1,38 @@
+Upstream-Status: backport
+
+Imported patch from: http://www.eglibc.org/archives/patches/msg01124.html
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/09
+
+Index: libc/posix/xregex.c
+===================================================================
+--- libc.orig/posix/xregex.c
++++ libc/posix/xregex.c
+@@ -2943,7 +2943,7 @@ PREFIX(regex_compile) (const char *ARG_P
+ _NL_CURRENT (LC_COLLATE,
+ _NL_COLLATE_INDIRECTWC);
+
+- idx = findidx ((const wint_t**)&cp);
++ idx = findidx ((const wint_t**)&cp, -1);
+ if (idx == 0 || cp < (wint_t*) str + c1)
+ /* This is no valid character. */
+ FREE_STACK_RETURN (REG_ECOLLATE);
+@@ -3392,7 +3392,7 @@ PREFIX(regex_compile) (const char *ARG_P
+ indirect = (const int32_t *)
+ _NL_CURRENT (LC_COLLATE, _NL_COLLATE_INDIRECTMB);
+
+- idx = findidx (&cp);
++ idx = findidx (&cp, -1);
+ if (idx == 0 || cp < str + c1)
+ /* This is no valid character. */
+ FREE_STACK_RETURN (REG_ECOLLATE);
+@@ -6363,7 +6363,7 @@ byte_re_match_2_internal (struct re_patt
+ }
+ str_buf[i] = TRANSLATE(*(d+i));
+ str_buf[i+1] = '\0'; /* sentinel */
+- idx2 = findidx ((const wint_t**)&cp);
++ idx2 = findidx ((const wint_t**)&cp, -1);
+ }
+
+ /* Update d, however d will be incremented at
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index 65ce9d3cb..340ec9930 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "17386"
DEPENDS += "gperf-native"
-PR = "r9"
+PR = "r10"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_15"
@@ -24,6 +24,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
file://GLRO_dl_debug_mask.patch \
file://initgroups_keys.patch \
file://use-localstatedir-for-vardbdir.patch \
+ file://eglibc_fix_findidx_parameters.patch \
"
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \