summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-12-20 14:52:56 -0500
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:28:21 +0000
commit88d27ef44823298251db33768ab2187f0ad9943e (patch)
tree6d7a9542419a6c1de8688fc8e672962f7c49aa4b
parentf93147633e0212a11d25fbfa56e221c0d8d1a9ac (diff)
downloadopenembedded-core-88d27ef44823298251db33768ab2187f0ad9943e.tar.gz
openembedded-core-88d27ef44823298251db33768ab2187f0ad9943e.tar.bz2
openembedded-core-88d27ef44823298251db33768ab2187f0ad9943e.tar.xz
openembedded-core-88d27ef44823298251db33768ab2187f0ad9943e.zip
qemu: match kernel headers to preferred kernel
As the yocto-kernel advances, the libc headers must also advance. This commit fixes the SRC_URI and SRCPV to work properly with the latest linux-yocto kernel. It also switches the qemu* targets to prefer this libc recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta/conf/machine/include/qemu.inc2
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb10
2 files changed, 5 insertions, 7 deletions
diff --git a/meta/conf/machine/include/qemu.inc b/meta/conf/machine/include/qemu.inc
index 502e24f77..d762d010c 100644
--- a/meta/conf/machine/include/qemu.inc
+++ b/meta/conf/machine/include/qemu.inc
@@ -16,6 +16,6 @@ RDEPENDS_kernel-base = ""
# Use a common kernel recipe for all QEMU machines
PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
-#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 051523395..762b6a8d2 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -6,14 +6,12 @@ B = "${S}"
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
PROVIDES = "linux-libc-headers"
-PV = "2.6.34+git-${SRCPV}"
-PR = "r1"
-
-SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;fullclone=1"
+PV = "2.6.37+git-${SRCPV}"
+PR = "r2"
SRCREV_FORMAT = "meta_machine"
-SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
- git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
+SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
+ git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
set_arch() {
case ${TARGET_ARCH} in