summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-11-30 16:52:28 +0000
committerRichard Purdie <richard@openedhand.com>2007-11-30 16:52:28 +0000
commit8e8b85df268143f19cd3a72e7275aafac582fc6b (patch)
tree0f34c825c04805f931caf64c8e8bc1cda5cc75ba
parentb6691acf0dacf6791e38bcb42f9303d27fa0a0e8 (diff)
downloadopenembedded-core-8e8b85df268143f19cd3a72e7275aafac582fc6b.tar.gz
openembedded-core-8e8b85df268143f19cd3a72e7275aafac582fc6b.tar.bz2
openembedded-core-8e8b85df268143f19cd3a72e7275aafac582fc6b.tar.xz
openembedded-core-8e8b85df268143f19cd3a72e7275aafac582fc6b.zip
git-native: Sync minor tweaks from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3286 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/git/files/autotools.patch26
-rw-r--r--meta/packages/git/git-native_1.5.3.bb3
-rw-r--r--meta/packages/git/git.inc8
3 files changed, 34 insertions, 3 deletions
diff --git a/meta/packages/git/files/autotools.patch b/meta/packages/git/files/autotools.patch
new file mode 100644
index 000000000..0666118cd
--- /dev/null
+++ b/meta/packages/git/files/autotools.patch
@@ -0,0 +1,26 @@
+Index: git-1.5.2.3/configure.ac
+===================================================================
+--- git-1.5.2.3.orig/configure.ac 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/configure.ac 2007-08-04 00:02:13.000000000 +0200
+@@ -235,7 +235,8 @@
+ else if (strcmp(buf, "12345"))
+ exit(2);]])],
+ [ac_cv_c_c99_format=yes],
+- [ac_cv_c_c99_format=no])
++ [ac_cv_c_c99_format=no],
++ [ac_cv_c_c99_format=yes])
+ ])
+ if test $ac_cv_c_c99_format = no; then
+ NO_C99_FORMAT=YesPlease
+Index: git-1.5.2.3/config.mak.in
+===================================================================
+--- git-1.5.2.3.orig/config.mak.in 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/config.mak.in 2007-08-04 00:07:04.000000000 +0200
+@@ -3,6 +3,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ AR = @AR@
+ TAR = @TAR@
+ #INSTALL = @INSTALL@ # needs install-sh or install.sh in sources
diff --git a/meta/packages/git/git-native_1.5.3.bb b/meta/packages/git/git-native_1.5.3.bb
index f91fd03ab..935c773c1 100644
--- a/meta/packages/git/git-native_1.5.3.bb
+++ b/meta/packages/git/git-native_1.5.3.bb
@@ -1,3 +1,4 @@
require git.inc
inherit native
-DEPENDS = "openssl-native curl-native"
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+PR = "r1"
diff --git a/meta/packages/git/git.inc b/meta/packages/git/git.inc
index 384dfaaee..7115d44b3 100644
--- a/meta/packages/git/git.inc
+++ b/meta/packages/git/git.inc
@@ -2,9 +2,14 @@ DESCRIPTION = "The git revision control system used by the Linux kernel develope
SECTION = "console/utils"
LICENSE = "GPL"
-SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1"
S = "${WORKDIR}/git-${PV}"
+EXTRA_OEMAKE = "NO_TCLTL=1"
+
+inherit autotools
+
do_install () {
oe_runmake install prefix=${D} bindir=${D}${bindir} \
template_dir=${D}${datadir}/git-core/templates \
@@ -12,4 +17,3 @@ do_install () {
}
FILES_${PN} += "${datadir}/git-core"
-