summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-12-12 14:52:04 +0000
committerRichard Purdie <richard@openedhand.com>2005-12-12 14:52:04 +0000
commit8fd58431099933596268fb47245e673cf55ce3c6 (patch)
treef4405b22fa75ec422d7012cb5cc80e057c5ba5ce
parent3c470b4e199b91c16da139eef47df253627f00e3 (diff)
downloadopenembedded-core-8fd58431099933596268fb47245e673cf55ce3c6.tar.gz
openembedded-core-8fd58431099933596268fb47245e673cf55ce3c6.tar.bz2
openembedded-core-8fd58431099933596268fb47245e673cf55ce3c6.tar.xz
openembedded-core-8fd58431099933596268fb47245e673cf55ce3c6.zip
oe/packages Updates from Openembedded
git-svn-id: https://svn.o-hand.com/repos/poky@189 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch73
-rw-r--r--openembedded/packages/console-tools/console-tools_0.3.2.bb5
-rw-r--r--openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch26
-rw-r--r--openembedded/packages/gmp/gmp_4.1.4.bb8
4 files changed, 107 insertions, 5 deletions
diff --git a/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch
new file mode 100644
index 000000000..47d7ea54b
--- /dev/null
+++ b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch
@@ -0,0 +1,73 @@
+Patch from Matthias Goebl <oe@m.goebl.net>
+Added via OE bugtracker: bug #478
+
+--- console-tools-0.3.2/kbdtools/kbd_mode.c.orig
++++ console-tools-0.3.2/kbdtools/kbd_mode.c
+@@ -29,11 +29,16 @@
+ OPT("-u --unicode ", _("UTF-8 mode (UNICODE)"));
+ OPT("-s --scancode ", _("scancode mode (RAW)"));
+ OPT(" --mode={8bit,keycode,unicode,scancode} ", _("set mode"));
++ OPT("-r --rate=RATE ", _("set repeat rate (default: 33)"));
++ OPT("-d --delay=DELAY ", _("set repeat delay (default: 250)"));
+
+ OPT("-h --help ", HELPDESC);
+ OPT("-V --version ", VERSIONDESC);
+ }
+
++int rate=-1;
++int delay=-1;
++
+ static int parse_cmdline (int argc, char *argv[])
+ {
+ int mode = -1;
+@@ -46,11 +51,13 @@
+ { "mode" , required_argument, NULL, 'm' },
+ { "scancode" , no_argument, NULL, 's' },
+ { "unicode" , no_argument, NULL, 'u' },
++ { "rate" , required_argument, NULL, 'r' },
++ { "delay" , required_argument, NULL, 'd' },
+ { NULL, 0, NULL, 0 }
+ };
+ int c;
+
+- while ( (c = getopt_long (argc, argv, "Vhaksu", long_opts, NULL)) != EOF)
++ while ( (c = getopt_long (argc, argv, "Vhaksur:d:", long_opts, NULL)) != EOF)
+ switch (c) {
+ case 'h':
+ usage ();
+@@ -58,6 +65,14 @@
+ case 'V':
+ version ();
+ exit(0);
++ case 'r':
++ rate = atoi(optarg);
++ mode = -2;
++ break;
++ case 'd':
++ delay = atoi(optarg);
++ mode = -2;
++ break;
+ case 'a':
+ mode = K_XLATE;
+ break;
+@@ -129,6 +144,20 @@
+ exit(0);
+ }
+
++ if ( rate != -1 || delay != -1 )
++ {
++ struct kbd_repeat kbd_rep;
++ kbd_rep.delay = delay;
++ kbd_rep.period = rate;
++ if (ioctl(fd, KDKBDREP, &kbd_rep))
++ {
++ fprintf(stderr, progname);
++ perror(_(": error setting keyboard repeat mode\n"));
++ exit(1);
++ }
++ if(mode==-2) exit(0);
++ }
++
+ if (ioctl(fd, KDSKBMODE, mode))
+ {
+ fprintf(stderr, progname);
diff --git a/openembedded/packages/console-tools/console-tools_0.3.2.bb b/openembedded/packages/console-tools/console-tools_0.3.2.bb
index 2a94a4f89..f7455825e 100644
--- a/openembedded/packages/console-tools/console-tools_0.3.2.bb
+++ b/openembedded/packages/console-tools/console-tools_0.3.2.bb
@@ -1,12 +1,13 @@
SECTION = "base"
LICENSE = "GPL"
DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch;patch=1 \
file://configure.patch;patch=1 \
file://compile.patch;patch=1 \
+ file://kbdrate.patch;patch=1 \
file://config/*.m4"
export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
@@ -43,4 +44,4 @@ pkg_prerm_${PN} () {
update-alternatives --remove deallocvt deallocvt.${PN}
update-alternatives --remove openvt openvt.${PN}
}
-
+
diff --git a/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch b/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch
new file mode 100644
index 000000000..1a01f6153
--- /dev/null
+++ b/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch
@@ -0,0 +1,26 @@
+--- gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:44:00 1.1
++++ gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:18:57
+@@ -29,8 +29,8 @@
+
+ .text
+ .align 2
+- .global ___gmpn_add_n
+-___gmpn_add_n:
++ .global __gmpn_add_n
++__gmpn_add_n:
+ mov #0,r3 ! clear cy save reg
+
+ Loop: mov.l @r5+,r1
+--- gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:44:04 1.1
++++ gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:18:59
+@@ -29,8 +29,8 @@
+
+ .text
+ .align 2
+- .global ___gmpn_sub_n
+-___gmpn_sub_n:
++ .global __gmpn_sub_n
++__gmpn_sub_n:
+ mov #0,r3 ! clear cy save reg
+
+ Loop: mov.l @r5+,r1
diff --git a/openembedded/packages/gmp/gmp_4.1.4.bb b/openembedded/packages/gmp/gmp_4.1.4.bb
index c9348ea43..d80e728dc 100644
--- a/openembedded/packages/gmp/gmp_4.1.4.bb
+++ b/openembedded/packages/gmp/gmp_4.1.4.bb
@@ -3,15 +3,17 @@ DESCRIPTION = "GNU multiprecision arithmetic library"
HOMEPAGE = "http://www.swox.com/gmp/"
LICENSE = "GPL LGPL"
+PR = "r1"
+
SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
- file://amd64.patch;patch=1"
+ file://amd64.patch;patch=1 \
+ file://sh4-asmfix.patch;patch=1"
inherit autotools
acpaths = ""
do_stage () {
- oe_libinstall -so libgmp ${STAGING_LIBDIR}
- install -m 0644 ${S}/gmp.h ${STAGING_INCDIR}/gmp.h
+ autotools_stage_all
}