summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 13:33:45 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 13:33:45 +0000
commit8ff6e5300ad50a8497da57ff437b3c2f710d7b3c (patch)
tree8e2641184b3c48e9f53eaa892fac5b059a0be1d9
parent6174a051040be2e78056011d4bbd226eb1550772 (diff)
downloadopenembedded-core-8ff6e5300ad50a8497da57ff437b3c2f710d7b3c.tar.gz
openembedded-core-8ff6e5300ad50a8497da57ff437b3c2f710d7b3c.tar.bz2
openembedded-core-8ff6e5300ad50a8497da57ff437b3c2f710d7b3c.tar.xz
openembedded-core-8ff6e5300ad50a8497da57ff437b3c2f710d7b3c.zip
lame: always link with libm (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3008 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/lame/lame/Makefile-lm.patch22
-rw-r--r--meta/packages/lame/lame_3.96.1.bb5
2 files changed, 25 insertions, 2 deletions
diff --git a/meta/packages/lame/lame/Makefile-lm.patch b/meta/packages/lame/lame/Makefile-lm.patch
new file mode 100644
index 000000000..cbbb1706c
--- /dev/null
+++ b/meta/packages/lame/lame/Makefile-lm.patch
@@ -0,0 +1,22 @@
+--- lame-3.96.1/libmp3lame/Makefile.am.old 2007-01-16 13:41:48.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.am 2007-01-16 13:41:53.000000000 +0000
+@@ -18,7 +18,7 @@
+ decoder_ldadd =
+ endif
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+
+--- lame-3.96.1/libmp3lame/Makefile.in.old 2007-01-16 13:47:17.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.in 2007-01-16 13:47:29.000000000 +0000
+@@ -177,7 +177,7 @@
+ @LIB_WITH_DECODER_TRUE@decoder_ldadd = $(top_builddir)/mpglib/libmpgdecoder.la
+ @LIB_WITH_DECODER_FALSE@decoder_ldadd =
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+
diff --git a/meta/packages/lame/lame_3.96.1.bb b/meta/packages/lame/lame_3.96.1.bb
index edb4265f1..0c5c24582 100644
--- a/meta/packages/lame/lame_3.96.1.bb
+++ b/meta/packages/lame/lame_3.96.1.bb
@@ -1,10 +1,11 @@
SECTION = "console/utils"
DESCRIPTION = "Not an MP3 encoder"
LICENSE = "LGPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
- file://no-gtk1.patch;patch=1"
+ file://no-gtk1.patch;patch=1 \
+ file://Makefile-lm.patch;patch=1"
inherit autotools