summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiping Ke <liping.ke@intel.com>2011-03-07 13:10:42 +0800
committerSaul Wold <sgw@linux.intel.com>2011-03-07 16:22:35 -0800
commit90d4624f0c5de6a35eace1f13c3e04df9737390c (patch)
treed2ae7bb19f5400061b19f1fc1d8a84946e440789
parent7ba79b4c25126b42d3697cec9ecdf8d688d6da54 (diff)
downloadopenembedded-core-90d4624f0c5de6a35eace1f13c3e04df9737390c.tar.gz
openembedded-core-90d4624f0c5de6a35eace1f13c3e04df9737390c.tar.bz2
openembedded-core-90d4624f0c5de6a35eace1f13c3e04df9737390c.tar.xz
openembedded-core-90d4624f0c5de6a35eace1f13c3e04df9737390c.zip
adt: Update to svn r596 to fix symbolic link issues
See the longlinksfix patch for details but symlinks over 100 chars long were broken in sdk tarballs and its due to problems in the inbuilt tar in libbb in opkg. svn r596 has already fixed the problem. Signed-off-by: Liping Ke <liping.ke@intel.com>
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc1
-rwxr-xr-xmeta/recipes-devtools/installer/adt-installer/adt_installer2
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb8
3 files changed, 6 insertions, 5 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index 5045c9e10..36202a119 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -140,6 +140,7 @@ OPKGSRCREV = "596"
SRCREV_pn-opkg ??= "${OPKGSRCREV}"
SRCREV_pn-opkg-native ??= "${OPKGSRCREV}"
SRCREV_pn-opkg-nativesdk ??= "${OPKGSRCREV}"
+SRCREV_pn-adt-installer ??= "${OPKGSRCREV}"
SRCREV_pn-opkg-nogpg ??= "${OPKGSRCREV}"
SRCREV_pn-opkg-nogpg-native ??= "${OPKGSRCREV}"
SRCREV_pn-opkg-nogpg-nativesdk ??= "${OPKGSRCREV}"
diff --git a/meta/recipes-devtools/installer/adt-installer/adt_installer b/meta/recipes-devtools/installer/adt-installer/adt_installer
index 2448d2b9f..b1b497002 100755
--- a/meta/recipes-devtools/installer/adt-installer/adt_installer
+++ b/meta/recipes-devtools/installer/adt-installer/adt_installer
@@ -170,7 +170,7 @@ if [ ! -x "$LOCAL_OPKG_LOC/bin/opkg-cl" ]; then
check_result
echo_info "Configure opkg ...\n"
- ./configure --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
+ ./autogen.sh --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
check_result
echo_info "Make opkg ...\n"
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index e8659716c..50290f9ff 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -39,7 +39,8 @@ YOCTOADT_VERSION = "${SDK_VERSION}"
inherit deploy
-SRC_URI = "http://opkg.googlecode.com/files/opkg-0.1.8.tar.gz \
+PV = "0.1.8+svnr${SRCPV}"
+SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://adt_installer \
file://scripts/adt_installer_internal \
file://scripts/util \
@@ -49,8 +50,6 @@ SRC_URI = "http://opkg.googlecode.com/files/opkg-0.1.8.tar.gz \
file://opkg/conf/opkg-sdk-x86_64.conf \
file://opkg/conf/opkg-sdk-i686.conf \
"
-SRC_URI[md5sum] = "c714ce0e4863bf1315e3b6913ffe3299"
-SRC_URI[sha256sum] = "ff94bf30bd662d49c4b5057e3a0818d062731adaa555d59abd677ec32a3c1c60"
fakeroot do_deploy () {
cd ${WORKDIR}
@@ -59,7 +58,8 @@ fakeroot do_deploy () {
rm -rf ${ADT_DIR}
mkdir -p ${ADT_DIR}/opkg/build
cp -r opkg ${ADT_DIR}/
- cp -r opkg-0.1.8 ${ADT_DIR}/opkg/build/
+ cp -r trunk ${ADT_DIR}/opkg/build/
+ mv ${ADT_DIR}/opkg/build/trunk ${ADT_DIR}/opkg/build/opkg-svn
cp -r scripts ${ADT_DIR}/
cp adt_installer ${ADT_DIR}
cp adt_installer.conf ${ADT_DIR}