summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
commit9ed0d2aa99a76a864d4793f54146c0e79e373712 (patch)
treebf6b07b0cfcc23ebb23130013e348ff84f38ce32
parent047f13b69a6907483a4cf71cf20c8434e20c8873 (diff)
downloadopenembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.gz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.bz2
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.xz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.zip
Add some extra packages to the image
git-svn-id: https://svn.o-hand.com/repos/poky@10 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/meta/meta-oh.bb34
-rw-r--r--openembedded/packages/meta/oh-image.bb4
-rw-r--r--openembedded/packages/rxvt/rxvt-2.7.9/include.patch16
-rw-r--r--openembedded/packages/rxvt/rxvt_2.7.9.bb41
-rw-r--r--openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb34
-rw-r--r--openembedded/packages/xauth/xauth/autofoo.patch148
-rw-r--r--openembedded/packages/xauth/xauth_cvs.bb13
-rw-r--r--openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch11
-rw-r--r--openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb9
-rw-r--r--openembedded/packages/xhost/xhost/autofoo.patch165
-rw-r--r--openembedded/packages/xhost/xhost_20040413.bb14
-rw-r--r--openembedded/packages/xmu/xmu_cvs.bb21
12 files changed, 492 insertions, 18 deletions
diff --git a/openembedded/packages/meta/meta-oh.bb b/openembedded/packages/meta/meta-oh.bb
index 12b7d2890..450afc207 100644
--- a/openembedded/packages/meta/meta-oh.bb
+++ b/openembedded/packages/meta/meta-oh.bb
@@ -1,38 +1,40 @@
-PACKAGES = oh-base-depends
+PACKAGES = "oh-base-depends oh-task-base"
# oh-task-base
DESCRIPTION = "Meta-package for OpenHand Palmtop Environment"
MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r0"
+PR = "r1"
ALLOW_EMPTY = "1"
oh-base-depends = "\
diet-x11 \
- matchbox \
virtual/xserver"
RDEPENDS_oh-base-depends := "${oh-base-depends}"
DEPENDS += " ${oh-base-depends}"
-#oh-task-base = "\
-# matchbox \
-# xcursor-transparent-theme \
-# rxvt-unicode \
+oh-task-base = "\
+ matchbox \
+ xcursor-transparent-theme \
+ rxvt \
+ xhost \
+ ttf-bitstream-vera \
+ xauth"
+
+# teleport \
# xst \
-# xhost \
-# xrdb \
-# ttf-bitstream-vera \
# libgtkstylus \
# detect-stylus \
-# teleport \
-# xauth"
-#
-#RDEPENDS_gpe-task-base := "gdk-pixbuf-loader-png \
+# xrdb \
+
+RDEPENDS_oh-task-base := "${oh-task-base}"
+
+# gdk-pixbuf-loader-png \
# gdk-pixbuf-loader-xpm \
# gdk-pixbuf-loader-jpeg \
# pango-module-basic-x \
# pango-module-basic-fc \
-# ${gpe-task-base}"
-#DEPENDS += " ${gpe-task-base}"
+
+DEPENDS += " ${oh-task-base}"
LICENSE = "MIT"
diff --git a/openembedded/packages/meta/oh-image.bb b/openembedded/packages/meta/oh-image.bb
index 668c7be46..27042725f 100644
--- a/openembedded/packages/meta/oh-image.bb
+++ b/openembedded/packages/meta/oh-image.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
export IMAGE_BASENAME = "oh-image"
@@ -10,8 +10,8 @@ DEPENDS = "task-bootstrap \
meta-oh"
export IPKG_INSTALL = "task-bootstrap \
+ oh-task-base \
${XSERVER} "
-#oh-task-base \
ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
diff --git a/openembedded/packages/rxvt/rxvt-2.7.9/include.patch b/openembedded/packages/rxvt/rxvt-2.7.9/include.patch
new file mode 100644
index 000000000..f7542843b
--- /dev/null
+++ b/openembedded/packages/rxvt/rxvt-2.7.9/include.patch
@@ -0,0 +1,16 @@
+diff -urN rxvt.orig/src/rxvtlib.h.in rxvt/src/rxvtlib.h.in
+--- rxvt.orig/src/rxvtlib.h.in 2003-03-25 19:13:53.000000000 -0500
++++ rxvt/src/rxvtlib.h.in 2004-04-03 20:35:13.000000000 -0500
+@@ -43,7 +43,11 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+
+-#include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++#include <X11/Xresource.h>
++#include <X11/Xproto.h>
++#include <X11/region.h>
+
+ #ifdef ENABLE_XFT
+ #include <X11/Xft/Xft.h>
diff --git a/openembedded/packages/rxvt/rxvt_2.7.9.bb b/openembedded/packages/rxvt/rxvt_2.7.9.bb
new file mode 100644
index 000000000..c201d16f8
--- /dev/null
+++ b/openembedded/packages/rxvt/rxvt_2.7.9.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Well known terminal emulator"
+SECTION = "x11/utils"
+PR = "r1"
+DEPENDS = "x11 libxft"
+LICENSE = "GPL"
+SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
+ file://include.patch;patch=1"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9"
+
+S = ${WORKDIR}/rxvt
+
+EXTRA_OECONF = "--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --with-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --with-x=${STAGING_LIBDIR}/.."
+
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+ echo '#define HAVE_UTMP_H 1' >> config.h
+ echo '#define HAVE_TTYSLOT 1' >> config.h
+}
diff --git a/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb b/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
new file mode 100644
index 000000000..b756c99e4
--- /dev/null
+++ b/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "Bitstream Vera"
+PACKAGE_ARCH = "all"
+PR = "r3"
+RDEPENDS = "libfontconfig-utils"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
+
+do_install () {
+ install -d ${D}${prefix}/share/fonts/ttf/
+ for i in *.ttf; do
+ install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ # fontconfig ships this too. not sure what to do about it.
+ #install -d ${D}${sysconfdir}/fonts
+ #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
+
+
+ install -d ${D}${prefix}/share/doc/${PN}/
+ for i in *.TXT; do
+ install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ done
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+
+FILES_${PN} = "/etc ${datadir}/fonts"
diff --git a/openembedded/packages/xauth/xauth/autofoo.patch b/openembedded/packages/xauth/xauth/autofoo.patch
new file mode 100644
index 000000000..d279a6f4f
--- /dev/null
+++ b/openembedded/packages/xauth/xauth/autofoo.patch
@@ -0,0 +1,148 @@
+diff -urN xauth.orig/Imakefile xauth/Imakefile
+--- xauth.orig/Imakefile 2004-04-23 21:54:38.000000000 +0200
++++ xauth/Imakefile 1970-01-01 01:00:00.000000000 +0100
+@@ -1,19 +0,0 @@
+-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:11 cpqbld Exp $
+-
+-
+-
+-
+-XCOMM $XFree86: xc/programs/xauth/Imakefile,v 3.5tsi Exp $
+-
+- DEPLIBS = $(DEPXAUTHLIB) $(DEPXMUULIB) $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XAUTHLIB) $(XMUULIB) $(XLIB)
+- SRCS = xauth.c gethost.c process.c parsedpy.c
+- OBJS = xauth.o gethost.o process.o parsedpy.o
+- CONN_DEFINES = $(CONNECTION_FLAGS)
+- DEPEND_DEFINES = $(CONN_DEFINES) $(SIGNAL_DEFINES)
+-
+-ComplexProgramTarget(xauth)
+-
+-SpecialCObjectRule(gethost,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
+-SpecialCObjectRule(process,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
+-SpecialCObjectRule(parsedpy,$(ICONFIGFILES),$(CONN_DEFINES))
+diff -urN xauth.orig/Makefile.am xauth/Makefile.am
+--- xauth.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xauth/Makefile.am 2004-08-14 13:20:37.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XAUTH_CFLAGS@
++
++bin_PROGRAMS = xauth
++
++xauth_SOURCES = gethost.c parsedpy.c process.c xauth.c xauth.h
++
++xauth_LDADD = @XAUTH_LIBS@
++
++man5_MANS=xauth.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xauth.orig/autogen.sh xauth/autogen.sh
+--- xauth.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ xauth/autogen.sh 2004-08-14 13:15:46.000000000 +0200
+@@ -0,0 +1,3 @@
++#! /bin/sh
++autoreconf -v --install || exit 1
++./configure --enable-maintainer-mode "$@"
+diff -urN xauth.orig/configure.ac xauth/configure.ac
+--- xauth.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xauth/configure.ac 2004-08-14 23:43:54.000000000 +0200
+@@ -0,0 +1,57 @@
++dnl
++dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xauth],4.4.0,[],xauth)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XAUTH, xau xext xmuu x11)
++
++AC_TYPE_SIGNAL
++
++# Transport selection
++AC_ARG_ENABLE(unix-transport,[ --disable-unix-transport ], [UNIXCONN=$enableval], [UNIXCONN=yes])
++AC_ARG_ENABLE(tcp-transport, [ --disable-tcp-transport ], [TCPCONN=$enableval], [TCPCONN=yes])
++AC_ARG_ENABLE(ipv6, [ --disable-ipv6 ], [IPV6CONN=$enableval], [IPV6CONN=yes])
++if test "$UNIXCONN" = "yes"; then
++ AC_DEFINE(UNIXCONN,1,[Support UNIX socket connections])
++fi
++if test "$TCPCONN" = "yes"; then
++ AC_DEFINE(TCPCONN,1,[Support TCP socket connections])
++fi
++if test "$IPV6CONN" = "yes"; then
++ AC_DEFINE(IPv6,1,[Support IPv6 for TCP connections])
++fi
++
++AC_OUTPUT([Makefile])
diff --git a/openembedded/packages/xauth/xauth_cvs.bb b/openembedded/packages/xauth/xauth_cvs.bb
new file mode 100644
index 000000000..ff615a500
--- /dev/null
+++ b/openembedded/packages/xauth/xauth_cvs.bb
@@ -0,0 +1,13 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE = "MIT"
+DEPENDS = "x11 xau xmu xext"
+DESCRIPTION = "X authority file utility"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "x11/base"
+PR = "r2"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xorg;module=xc/programs/xauth \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/xauth"
+
+inherit autotools pkgconfig
diff --git a/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch b/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
new file mode 100644
index 000000000..df28dfbc8
--- /dev/null
+++ b/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
@@ -0,0 +1,11 @@
+diff -ur xcursor-transparent-theme-0.1.1~/cursors/Makefile.am xcursor-transparent-theme-0.1.1/cursors/Makefile.am
+--- xcursor-transparent-theme-0.1.1~/cursors/Makefile.am 2003-10-30 12:13:59.000000000 +0000
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2004-07-27 12:56:24.000000000 +0100
+@@ -91,6 +91,6 @@
+ $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
+ for CURSOR in $(CURSOR_NAMES); do \
+ echo '-- Installing cursor '$$CURSOR; \
+- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
++ ln -s transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ done
+
diff --git a/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb b/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
new file mode 100644
index 000000000..ac03be504
--- /dev/null
+++ b/openembedded/packages/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+DESCRIPTION = "Transparent xcursor theme for handheld systems"
+SECTION = "x11/base"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
+ file://use-relative-symlinks.patch;patch=1"
+FILES_${PN} = "${datadir}/icons/xcursor-transparent/cursors/*"
+
+inherit autotools
diff --git a/openembedded/packages/xhost/xhost/autofoo.patch b/openembedded/packages/xhost/xhost/autofoo.patch
new file mode 100644
index 000000000..b29f017ab
--- /dev/null
+++ b/openembedded/packages/xhost/xhost/autofoo.patch
@@ -0,0 +1,165 @@
+diff -urN xhost.orig/Imakefile xhost/Imakefile
+--- xhost.orig/Imakefile 2003-11-14 16:54:53.000000000 +0100
++++ xhost/Imakefile 1970-01-01 01:00:00.000000000 +0100
+@@ -1,16 +0,0 @@
+-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:24 cpqbld Exp $
+-#if HasSecureRPC
+-RPC_DEFINES = -DSECURE_RPC
+-#else
+-RPC_DEFINES =
+-#endif
+-KRB5_DEFINES = Krb5Defines
+-KRB5_INCLUDE = Krb5Includes
+- INCLUDES = $(KRB5_INCLUDE)
+- DEPLIBS = $(DEPXMULIB) $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XMULIB) $(XLIB)
+- SRCS = xhost.c
+- OBJS = xhost.o
+- DEFINES = ConnectionFlags $(SIGNAL_DEFINES) $(RPC_DEFINES) $(KRB5_DEFINES)
+-
+-ComplexProgramTarget(xhost)
+diff -urN xhost.orig/Makefile.am xhost/Makefile.am
+--- xhost.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xhost/Makefile.am 2004-08-15 17:43:47.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XHOST_CFLAGS@
++
++bin_PROGRAMS = xhost
++
++xhost_SOURCES = xhost.c
++
++xhost_LDADD = @XHOST_LIBS@
++
++man5_MANS=xhost.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xhost.orig/configure.ac xhost/configure.ac
+--- xhost.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xhost/configure.ac 2004-08-15 17:43:42.000000000 +0200
+@@ -0,0 +1,57 @@
++dnl
++dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xhost],4.4.0,[],xhost)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XHOST, xext xmuu x11)
++
++AC_TYPE_SIGNAL
++
++# Transport selection
++AC_ARG_ENABLE(unix-transport,[ --disable-unix-transport ], [UNIXCONN=$enableval], [UNIXCONN=yes])
++AC_ARG_ENABLE(tcp-transport, [ --disable-tcp-transport ], [TCPCONN=$enableval], [TCPCONN=yes])
++AC_ARG_ENABLE(ipv6, [ --disable-ipv6 ], [IPV6CONN=$enableval], [IPV6CONN=yes])
++if test "$UNIXCONN" = "yes"; then
++ AC_DEFINE(UNIXCONN,1,[Support UNIX socket connections])
++fi
++if test "$TCPCONN" = "yes"; then
++ AC_DEFINE(TCPCONN,1,[Support TCP socket connections])
++fi
++if test "$IPV6CONN" = "yes"; then
++ AC_DEFINE(IPv6,1,[Support IPv6 for TCP connections])
++fi
++
++AC_OUTPUT([Makefile])
+diff -urN xhost.orig/xhost.c xhost/xhost.c
+--- xhost.orig/xhost.c 2003-11-14 16:54:53.000000000 +0100
++++ xhost/xhost.c 2004-08-15 17:53:07.000000000 +0200
+@@ -27,6 +27,10 @@
+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #if defined(TCPCONN) || defined(STREAMSCONN)
+ #define NEEDSOCKETS
+ #endif
+@@ -102,11 +106,7 @@
+ static int local_xerror();
+ static char *get_hostname();
+
+-#ifdef SIGNALRETURNSINT
+-#define signal_t int
+-#else
+-#define signal_t void
+-#endif
++#define signal_t RETSIGTYPE
+ static signal_t nameserver_lost();
+
+ #define NAMESERVER_TIMEOUT 5 /* time to wait for nameserver */
diff --git a/openembedded/packages/xhost/xhost_20040413.bb b/openembedded/packages/xhost/xhost_20040413.bb
new file mode 100644
index 000000000..7245e7164
--- /dev/null
+++ b/openembedded/packages/xhost/xhost_20040413.bb
@@ -0,0 +1,14 @@
+FIXEDCVSDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
+LICENSE = "MIT"
+PV = "0.0cvs${FIXEDCVSDATE}"
+DEPENDS = "x11 xext xmu"
+DESCRIPTION = "server access control program for X"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "x11/base"
+PR = "r2"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xorg;module=xc/programs/xhost;date=${FIXEDCVSDATE} \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/xhost"
+
+inherit autotools pkgconfig
diff --git a/openembedded/packages/xmu/xmu_cvs.bb b/openembedded/packages/xmu/xmu_cvs.bb
new file mode 100644
index 000000000..c7e5f8461
--- /dev/null
+++ b/openembedded/packages/xmu/xmu_cvs.bb
@@ -0,0 +1,21 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE = "MIT"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "xt xext"
+PR = "r2"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xmu"
+S = "${WORKDIR}/Xmu"
+
+PACKAGES =+ "xmuu xmuu-dev"
+
+FILES_xmuu = "${libdir}/libXmuu.so.*"
+FILES_xmuu-dev = "${libdir}/libXmuu.so"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
+}