summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 11:52:05 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 11:52:05 +0000
commita0d0bd249a37d39d4301963e86a9b0019b619599 (patch)
tree8f29c8ce82f8acfa22ca69734e0f9120e31c1329
parentb33f6c2843b58acd036eb06ba6ffa0b1ca18e801 (diff)
downloadopenembedded-core-a0d0bd249a37d39d4301963e86a9b0019b619599.tar.gz
openembedded-core-a0d0bd249a37d39d4301963e86a9b0019b619599.tar.bz2
openembedded-core-a0d0bd249a37d39d4301963e86a9b0019b619599.tar.xz
openembedded-core-a0d0bd249a37d39d4301963e86a9b0019b619599.zip
gpgme: split packaging to package per library
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4112 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/gpgme/gpgme_1.1.4.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/packages/gpgme/gpgme_1.1.4.bb b/meta/packages/gpgme/gpgme_1.1.4.bb
index 120a07e2a..8ac8bb339 100644
--- a/meta/packages/gpgme/gpgme_1.1.4.bb
+++ b/meta/packages/gpgme/gpgme_1.1.4.bb
@@ -1,7 +1,8 @@
+DESCRIPTION = "GPGME - GnuPG Made Easy"
LICENSE = "GPL"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
DEPENDS = "libgpg-error pth"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test \
--with-gpg=${bindir}/gpg --without-gpgsm"
@@ -20,4 +21,8 @@ do_stage() {
install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
}
+PACKAGES =+ "${PN}-pth ${PN}-pthread"
+FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
+FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
+FILES_${PN} = "${libdir}/libgpgme.so.*"
FILES_${PN}-dev += "${bindir}/gpgme-config"