summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-21 13:21:49 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 21:44:37 +0100
commitb376a803cac9c6403ce7ddf2a4a479292ec9ba85 (patch)
treeb642f0fbe43e030348858dde2c564b970d88d2d1
parent8a251accbfd68078fbab23a96411b76928cf1063 (diff)
downloadopenembedded-core-b376a803cac9c6403ce7ddf2a4a479292ec9ba85.tar.gz
openembedded-core-b376a803cac9c6403ce7ddf2a4a479292ec9ba85.tar.bz2
openembedded-core-b376a803cac9c6403ce7ddf2a4a479292ec9ba85.tar.xz
openembedded-core-b376a803cac9c6403ce7ddf2a4a479292ec9ba85.zip
module-init-tools: upgrade to 3.12
[Patches] KEEP _ignore_arch_directory_: ignore /etc/modprobe.d/arch, not sure reason now. keep it and to be verified later REMOVE _module-init-tools-remove-index.patch_: in upstream NEW _disable_man.patch_: a simpler patch to replace below removed two REMOVE _manpagesopt_: due to above new patch REMOVE _no_man_rebuild_: ditto KEEP _modutils_extension_: poky has its own name convention and thus need such knowledge in code [Recipe] - adjust indention - remove some old lines like ${S} and EXTRA_OECONF Signed-off-by: Kevin Tian <kevin.tian@intel.com>
-rw-r--r--meta/packages/module-init-tools/files/disable_man.patch23
-rw-r--r--meta/packages/module-init-tools/files/ignore_arch_directory24
-rw-r--r--meta/packages/module-init-tools/files/ignore_arch_directory.patch28
-rw-r--r--meta/packages/module-init-tools/files/manpagesopt41
-rw-r--r--meta/packages/module-init-tools/files/module-init-tools-remove-index.patch14
-rw-r--r--meta/packages/module-init-tools/files/modutils_extension55
-rw-r--r--meta/packages/module-init-tools/files/modutils_extension.patch22
-rw-r--r--meta/packages/module-init-tools/files/no-static-binaries.patch24
-rw-r--r--meta/packages/module-init-tools/files/no_man_rebuild12
-rw-r--r--meta/packages/module-init-tools/module-init-tools-cross_3.12.bb (renamed from meta/packages/module-init-tools/module-init-tools-cross_3.2.2.bb)4
-rw-r--r--meta/packages/module-init-tools/module-init-tools.inc20
-rw-r--r--meta/packages/module-init-tools/module-init-tools_3.12.bb39
-rw-r--r--meta/packages/module-init-tools/module-init-tools_3.2.2.bb42
13 files changed, 134 insertions, 214 deletions
diff --git a/meta/packages/module-init-tools/files/disable_man.patch b/meta/packages/module-init-tools/files/disable_man.patch
new file mode 100644
index 000000000..daf58248b
--- /dev/null
+++ b/meta/packages/module-init-tools/files/disable_man.patch
@@ -0,0 +1,23 @@
+# disable man page build
+#
+# by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
+
+diff --git a/Makefile.am b/Makefile.am
+index 6f83c12..32972a8 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,13 +39,12 @@ modindex_LDADD = $(LDADD) libmodtools.a
+ MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5
+ MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
+ SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
+-dist_man_MANS = $(MAN5) $(MAN8)
+ # If they haven't overridden mandir, fix it (never /man!)
+ mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
+
+ TESTSUITE := $(shell test -e @srcdir@/tests && find @srcdir@/tests -type f ! -name '*~')
+
+-EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
++EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care
+
+ sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo
+ if BUILD_STATIC_UTILS
diff --git a/meta/packages/module-init-tools/files/ignore_arch_directory b/meta/packages/module-init-tools/files/ignore_arch_directory
deleted file mode 100644
index 185ea7a3a..000000000
--- a/meta/packages/module-init-tools/files/ignore_arch_directory
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8
---- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200
-+++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200
-@@ -31,6 +31,7 @@
- \fI/etc/modprobe.conf\fR configuration file and
- \fI/etc/modprobe.d\fR directory
- (see \fBmodprobe.conf\fR(5)).
-+All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored.
- .PP
- Note that this version of \fBmodprobe\fR does not
- do anything to the module itself: the work of resolving symbols
---- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200
-+++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200
-@@ -1158,6 +1158,10 @@
- DIR *dir;
- int ret = 0;
-
-+ /* ignore everything in this directory */
-+ if (streq(filename, "/etc/modprobe.d/arch"))
-+ return 1;
-+
- /* Reiser4 has file/directory duality: treat it as both. */
- dir = opendir(filename);
- if (dir) {
diff --git a/meta/packages/module-init-tools/files/ignore_arch_directory.patch b/meta/packages/module-init-tools/files/ignore_arch_directory.patch
new file mode 100644
index 000000000..7b3082480
--- /dev/null
+++ b/meta/packages/module-init-tools/files/ignore_arch_directory.patch
@@ -0,0 +1,28 @@
+# not sure the reason yet. Keep for a while and verify later.
+#
+# comments added by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
+
+diff -ruN module-init-tools-3.12.orig/modprobe.8 module-init-tools-3.12/modprobe.8
+--- module-init-tools-3.12/modprobe.8.orig
++++ module-init-tools-3.12/modprobe.8
+@@ -27,6 +27,7 @@
+ (see \fBmodprobe.conf\fR(5)). \fBmodprobe\fR will also use module
+ options specified on the kernel command line in the form of
+ <module>\&.<option>\&.
++All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored.
+ .PP
+ Note that unlike in 2.4 series Linux kernels (which are not supported
+ by this tool) this version of \fBmodprobe\fR does not
+--- module-init-tools-3.12/modprobe.c.orig
++++ module-init-tools-3.12/modprobe.c
+@@ -1052,6 +1052,10 @@
+ DIR *dir;
+ int ret = 0;
+
++ /* ignore everything in this directory */
++ if (streq(filename, "/etc/modprobe.d/arch"))
++ return 1;
++
+ dir = opendir(filename);
+ if (dir) {
+ struct file_entry {
diff --git a/meta/packages/module-init-tools/files/manpagesopt b/meta/packages/module-init-tools/files/manpagesopt
deleted file mode 100644
index 5d5cac609..000000000
--- a/meta/packages/module-init-tools/files/manpagesopt
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: module-init-tools-3.2-pre9/configure.in
-===================================================================
---- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000
-+++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000
-@@ -41,5 +41,14 @@
- fi])
- AC_SUBST(MODULE_DIR)
-
--AC_OUTPUT([Makefile])
-+AC_ARG_ENABLE(manpages,
-+[ --disable-manpages Disable man page generation.],
-+[if test x"$enableval" != x"no"; then
-+ enable_manpages=yes
-+else
-+ enable_manpages=no
-+fi],
-+[enable_manpages=yes])
-+AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes")
-
-+AC_OUTPUT([Makefile])
-Index: module-init-tools-3.2-pre9/Makefile.am
-===================================================================
---- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000
-+++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000
-@@ -21,13 +21,14 @@
- MAN5 = modprobe.conf.5 modules.dep.5
- MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
- SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
--man_MANS = $(MAN5) $(MAN8)
- # If they haven't overridden mandir, fix it (never /man!)
- mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
-
- TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions
-
--EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
-+if MANPAGES
-+man_MANS = $(MAN5) $(MAN8)
-+endif
-
- sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static
- bin_PROGRAMS = lsmod
diff --git a/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch b/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch
deleted file mode 100644
index c56532e00..000000000
--- a/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://uclibc.org/cgi-bin/viewcvs.cgi/trunk/buildroot/package/module-init-tools/module-init-tools-remove-index.patch?rev=16782&view=auto
-
-diff -ur module-init-tools-3.2.2/modprobe.c module-init-tools-3.2.2-patched/modprobe.c
---- module-init-tools-3.2.2/modprobe.c 2005-12-01 17:42:09.000000000 -0600
-+++ module-init-tools-3.2.2-patched/modprobe.c 2006-12-04 19:50:50.353237649 -0600
-@@ -270,7 +270,7 @@
- char *modname;
-
- /* Ignore lines without : or which start with a # */
-- ptr = index(line, ':');
-+ ptr = strchr(line, ':');
- if (ptr == NULL || line[strspn(line, "\t ")] == '#')
- return 0;
-
diff --git a/meta/packages/module-init-tools/files/modutils_extension b/meta/packages/module-init-tools/files/modutils_extension
deleted file mode 100644
index fd84ca255..000000000
--- a/meta/packages/module-init-tools/files/modutils_extension
+++ /dev/null
@@ -1,55 +0,0 @@
---- module-init-tools-3.0-pre10.orig/depmod.c
-+++ module-init-tools-3.0-pre10/depmod.c
-@@ -217,13 +217,13 @@
- {
- char *sep;
- char pathname[strlen(argv[0])+1];
-- char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".old")];
-+ char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".24")];
-
- memset(pathname, 0, strlen(argv[0])+1);
- sep = strrchr(argv[0], '/');
- if (sep)
- memcpy(pathname, argv[0], sep - argv[0]+1);
-- sprintf(oldname, "%s%s.old", pathname, "depmod");
-+ sprintf(oldname, "%s%s.24", pathname, "depmod");
-
- /* Recursion detection: we need an env var since we can't
- change argv[0] (as older modutils uses it to determine
---- module-init-tools-3.0-pre10.orig/backwards_compat.c
-+++ module-init-tools-3.0-pre10/backwards_compat.c
-@@ -21,13 +21,13 @@
- pid_t pid;
- char ascii_pid[32];
- char pathname[strlen(argv[0])+1];
-- char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".old")];
-+ char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".24")];
-
- memset(pathname, 0, strlen(argv[0])+1);
- sep = strrchr(argv[0], '/');
- if (sep)
- memcpy(pathname, argv[0], sep - argv[0]+1);
-- sprintf(oldname, "%s%s.old", pathname, progname);
-+ sprintf(oldname, "%s%s.24", pathname, progname);
-
- /* Recursion detection: we need an env var since we can't
- change argv[0] (as older modutils uses it to determine
---- module-init-tools-3.0-pre10.orig/generate-modprobe.conf
-+++ module-init-tools-3.0-pre10/generate-modprobe.conf
-@@ -26,12 +26,12 @@
- cp $TESTING_MODPROBE_CONF $MODPROBECONF
- elif [ "$STDIN" = "1" ]; then
- cat > $MODPROBECONF
--elif [ -x /sbin/modprobe.old ]; then
-+elif [ -x /sbin/modprobe.24 ]; then
- # In sbin.
-- /sbin/modprobe.old -c > $MODPROBECONF
--elif modprobe.old -c >/dev/null 2>&1; then
-+ /sbin/modprobe.24 -c > $MODPROBECONF
-+elif modprobe.24 -c >/dev/null 2>&1; then
- # Somewhere in path.
-- modprobe.old -c > $MODPROBECONF
-+ modprobe.24 -c > $MODPROBECONF
- elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then
- # Running /sbin/modprobe gives old version.
- /sbin/modprobe -c > $MODPROBECONF
diff --git a/meta/packages/module-init-tools/files/modutils_extension.patch b/meta/packages/module-init-tools/files/modutils_extension.patch
new file mode 100644
index 000000000..128c9531a
--- /dev/null
+++ b/meta/packages/module-init-tools/files/modutils_extension.patch
@@ -0,0 +1,22 @@
+# poky uses new name to differentiate from modutils, so reflect this new name in source
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
+--- module-init-tools-3.0-pre10.orig/generate-modprobe.conf
++++ module-init-tools-3.0-pre10/generate-modprobe.conf
+@@ -45,12 +45,12 @@
+ cp $TESTING_MODPROBE_CONF $MODPROBECONF
+ elif [ "$STDIN" = "1" ]; then
+ cat > $MODPROBECONF
+-elif [ -x /sbin/modprobe.old ]; then
++elif [ -x /sbin/modprobe.24 ]; then
+ # In sbin.
+- /sbin/modprobe.old -c > $MODPROBECONF || modprobe_abort
+-elif modprobe.old -c >/dev/null 2>&1; then
++ /sbin/modprobe.24 -c > $MODPROBECONF || modprobe_abort
++elif modprobe.24 -c >/dev/null 2>&1; then
+ # Somewhere in path.
+- modprobe.old -c > $MODPROBECONF || modprobe_abort
++ modprobe.24 -c > $MODPROBECONF || modprobe_abort
+ elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then
+ # Running /sbin/modprobe gives old version.
+ /sbin/modprobe -c > $MODPROBECONF || modprobe_abort
diff --git a/meta/packages/module-init-tools/files/no-static-binaries.patch b/meta/packages/module-init-tools/files/no-static-binaries.patch
index a9fbb27bf..ca83ec075 100644
--- a/meta/packages/module-init-tools/files/no-static-binaries.patch
+++ b/meta/packages/module-init-tools/files/no-static-binaries.patch
@@ -3,25 +3,21 @@
# so this patch just removes it.
#
# - jdike@linux.intel.com
+#
+# Change to a simpler method by just disabling static link flag, since even
+# removing those lines don't prevent insmod.static from compile
+#
+# by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
Index: module-init-tools-3.2.2/Makefile.am
===================================================================
--- module-init-tools-3.2.2.orig/Makefile.am 2010-05-26 15:43:16.000000000 -0400
+++ module-init-tools-3.2.2/Makefile.am 2010-05-26 16:04:06.232990785 -0400
-@@ -5,16 +5,10 @@ rmmod_SOURCES = rmmod.c testing.h
- depmod_SOURCES = depmod.c moduleops.c tables.c zlibsupport.c depmod.h moduleops.h tables.h list.h testing.h zlibsupport.h
- modinfo_SOURCES = modinfo.c zlibsupport.c testing.h zlibsupport.h
+@@ -10,7 +10,6 @@
+ modindex_SOURCES = modindex.c zlibsupport.c zlibsupport.h testing.h
--insmod_static_SOURCES = insmod.c
+ insmod_static_SOURCES = insmod.c
-insmod_static_LDFLAGS = -static
--# We don't want the $(zlib_flags) here: that makes a dynamic executable
--insmod_static_LDADD =
--
- EXTRA_insmod_SOURCES = backwards_compat.c
- EXTRA_lsmod_SOURCES = backwards_compat.c
- EXTRA_modprobe_SOURCES = backwards_compat.c
- EXTRA_rmmod_SOURCES = backwards_compat.c
--EXTRA_insmod_static_SOURCES = backwards_compat.c
- EXTRA_depmod_SOURCES = moduleops_core.c
- EXTRA_modinfo_SOURCES = backwards_compat.c
+ # We don't want the $(zlib_flags) here: that makes a dynamic executable
+ insmod_static_LDADD = libmodtools.a
diff --git a/meta/packages/module-init-tools/files/no_man_rebuild b/meta/packages/module-init-tools/files/no_man_rebuild
deleted file mode 100644
index d38866aec..000000000
--- a/meta/packages/module-init-tools/files/no_man_rebuild
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN module-init-tools-3.1.orig/Makefile.in module-init-tools-3.1/Makefile.in
---- module-init-tools-3.1.orig/Makefile.in 2004-11-15 01:59:48.000000000 +0100
-+++ module-init-tools-3.1/Makefile.in 2004-11-21 02:18:58.000000000 +0100
-@@ -613,7 +613,7 @@
- check-am: all-am
- $(MAKE) $(AM_MAKEFLAGS) check-TESTS
- check: check-am
--all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(MANS)
-+all-am: Makefile $(PROGRAMS) $(SCRIPTS) #$(MANS)
-
- installdirs:
- $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(man5dir) $(DESTDIR)$(man8dir)
diff --git a/meta/packages/module-init-tools/module-init-tools-cross_3.2.2.bb b/meta/packages/module-init-tools/module-init-tools-cross_3.12.bb
index 02a69193a..c4b411846 100644
--- a/meta/packages/module-init-tools/module-init-tools-cross_3.2.2.bb
+++ b/meta/packages/module-init-tools/module-init-tools-cross_3.12.bb
@@ -1,9 +1,9 @@
require module-init-tools.inc
-PR = "r4"
+PR = "r0"
inherit cross
PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6"
-SRC_URI += "file://no-static-binaries.patch;patch=1"
+SRC_URI += "file://no-static-binaries.patch"
EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}"
diff --git a/meta/packages/module-init-tools/module-init-tools.inc b/meta/packages/module-init-tools/module-init-tools.inc
index 2db6bcd54..7c9b3f7fa 100644
--- a/meta/packages/module-init-tools/module-init-tools.inc
+++ b/meta/packages/module-init-tools/module-init-tools.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "This package contains a set of programs for loading, inserting, and removing kernel modules for Linux (versions 2.5.48 and above). It serves the same function that the modutils package serves for Linux 2.4"
-LICENSE = "GPLv2"
+LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://lsmod.c;md5=030a1ab6b7b2b97e9959db0d5f1c093d"
+ file://lsmod.c;md5=743c873ec42632d2ce37d3c440f366dd"
SECTION = "base"
PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
@@ -11,13 +11,13 @@ FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
- file://ignore_arch_directory;apply=yes \
- file://modutils_extension;apply=yes \
- file://no_man_rebuild;apply=yes \
- file://manpagesopt;apply=yes \
- file://module-init-tools-remove-index.patch;"
-S = "${WORKDIR}/module-init-tools-${PV}"
-
-EXTRA_OECONF = "--disable-manpages"
+ file://ignore_arch_directory.patch \
+ file://modutils_extension.patch \
+ file://disable_man.patch"
inherit autotools
+
+# module-init-tools uses AX_ENABLE_BUILDDIR to move rest of configuration steps
+# into a subdir. However this macro is not quite cross friendly. Instead of
+# mangling that macro, a easier way is to take the disable option
+EXTRA_OECONF = "--disable-builddir"
diff --git a/meta/packages/module-init-tools/module-init-tools_3.12.bb b/meta/packages/module-init-tools/module-init-tools_3.12.bb
new file mode 100644
index 000000000..6fd9d9dc0
--- /dev/null
+++ b/meta/packages/module-init-tools/module-init-tools_3.12.bb
@@ -0,0 +1,39 @@
+require module-init-tools.inc
+PR = "r0"
+
+# autotools set prefix to /usr, however we want them in /bin and /sbin
+bindir = "/bin"
+sbindir = "/sbin"
+
+do_install() {
+ autotools_do_install
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
+ mv ${D}/$f ${D}/$f.26
+ done
+}
+
+pkg_postinst_module-init-tools() {
+ for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+ bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.26 60
+ done
+ update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
+ update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
+}
+
+pkg_prerm_module-init-tools() {
+ for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+ bn=`basename $f`
+ update-alternatives --remove $bn /$f.26
+ done
+ update-alternatives --remove bin-lsmod /bin/lsmod.26
+ update-alternatives --remove lsmod /bin/lsmod.26
+}
+
+pkg_postinst_module-init-tools-depmod() {
+ update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
+}
+
+pkg_prerm_module-init-tools-depmod() {
+ update-alternatives --remove depmod /sbin/depmod.26
+}
diff --git a/meta/packages/module-init-tools/module-init-tools_3.2.2.bb b/meta/packages/module-init-tools/module-init-tools_3.2.2.bb
deleted file mode 100644
index 4977049b8..000000000
--- a/meta/packages/module-init-tools/module-init-tools_3.2.2.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-require module-init-tools.inc
-PR = "r3"
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-do_install() {
- autotools_do_install
- for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
- mv ${D}/$f ${D}/$f.26
- done
-}
-
-pkg_postinst_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
-bn=`basename $f`
- update-alternatives --install /$f $bn /$f.26 60
-done
-update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
-update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
-}
-
-pkg_prerm_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
-bn=`basename $f`
- update-alternatives --remove $bn /$f.26
-done
-update-alternatives --remove bin-lsmod /bin/lsmod.26
-update-alternatives --remove lsmod /bin/lsmod.26
-}
-
-pkg_postinst_module-init-tools-depmod() {
-#!/bin/sh
-update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
-}
-
-pkg_prerm_module-init-tools-depmod() {
-#!/bin/sh
-update-alternatives --remove depmod /sbin/depmod.26
-}