summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-24 16:24:00 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-24 16:24:00 +0000
commitbad1deb6b133fcdab56d6eab7c39092cbafd268d (patch)
tree8317ee8e249f8d87c9da27a9d232f1cfd1db66cf
parent379cac88fd4f37ced33b0f4a995a039e21b57c55 (diff)
downloadopenembedded-core-bad1deb6b133fcdab56d6eab7c39092cbafd268d.tar.gz
openembedded-core-bad1deb6b133fcdab56d6eab7c39092cbafd268d.tar.bz2
openembedded-core-bad1deb6b133fcdab56d6eab7c39092cbafd268d.tar.xz
openembedded-core-bad1deb6b133fcdab56d6eab7c39092cbafd268d.zip
qemu: Fix build problems in paths with symlinks
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3588 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/qemu/qemu-0.9.1/configure_symlinkpath_fix.patch28
-rw-r--r--meta/packages/qemu/qemu_0.9.1.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta/packages/qemu/qemu-0.9.1/configure_symlinkpath_fix.patch b/meta/packages/qemu/qemu-0.9.1/configure_symlinkpath_fix.patch
new file mode 100644
index 000000000..3ec304a38
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.9.1/configure_symlinkpath_fix.patch
@@ -0,0 +1,28 @@
+Index: qemu-0.9.1/configure
+===================================================================
+--- qemu-0.9.1.orig/configure 2008-01-24 15:33:13.000000000 +0000
++++ qemu-0.9.1/configure 2008-01-24 15:45:50.000000000 +0000
+@@ -209,15 +209,17 @@
+
+ # find source path
+ source_path=`dirname "$0"`
++source_path_used="no"
++workdir=`pwd`
++workdir=`readlink -f $workdir`
+ if [ -z "$source_path" ]; then
+- source_path=`pwd`
++ source_path=$workdir
+ else
+ source_path=`cd "$source_path"; pwd`
+-fi
+-if test "$source_path" = `pwd` ; then
+- source_path_used="no"
+-else
+- source_path_used="yes"
++ source_path=`readlink -f $source_path`
++ if test "$source_path" != "$workdir" ; then
++ source_path_used="yes"
++ fi
+ fi
+
+ werror="no"
diff --git a/meta/packages/qemu/qemu_0.9.1.bb b/meta/packages/qemu/qemu_0.9.1.bb
index ed00f700e..030eb8350 100644
--- a/meta/packages/qemu/qemu_0.9.1.bb
+++ b/meta/packages/qemu/qemu_0.9.1.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
SRCDATE = "20071230"
-PR = "r3"
+PR = "r4"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}:${FILE_DIRNAME}/files"
FILESDIR = "${WORKDIR}"
@@ -32,6 +32,7 @@ SRC_URI = "\
file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
file://workaround_bad_futex_headers.patch;patch=1 \
file://fix_segfault.patch;patch=1 \
+ file://configure_symlinkpath_fix.patch;patch=1 \
file://disable-error-in-configure.patch;patch=1"
# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \