summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-04-14 22:19:30 +0000
committerRichard Purdie <richard@openedhand.com>2008-04-14 22:19:30 +0000
commitca0f459c950823cbf4944132d0082d1feda7c4f4 (patch)
treeb6d875c996de54abe2531c28b2f9e18454187fe4
parent50f74c5b385f9968be1c0dc70eea03ef29061d5b (diff)
downloadopenembedded-core-ca0f459c950823cbf4944132d0082d1feda7c4f4.tar.gz
openembedded-core-ca0f459c950823cbf4944132d0082d1feda7c4f4.tar.bz2
openembedded-core-ca0f459c950823cbf4944132d0082d1feda7c4f4.tar.xz
openembedded-core-ca0f459c950823cbf4944132d0082d1feda7c4f4.zip
gstreamer: Remove horrible lib-link.m4 macro file which breaks libtool 2.2.2 with search path insanity
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4256 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb7
-rw-r--r--meta/packages/gstreamer/gst-plugins-base_0.10.17.bb4
-rw-r--r--meta/packages/gstreamer/gst-plugins-good_0.10.6.bb7
-rw-r--r--meta/packages/gstreamer/gst-plugins-ugly_0.10.6.bb6
-rw-r--r--meta/packages/gstreamer/gstreamer_0.10.17.bb5
5 files changed, 26 insertions, 3 deletions
diff --git a/meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb b/meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb
index 078e60429..d6023aae1 100644
--- a/meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb
+++ b/meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb
@@ -1,6 +1,6 @@
require gst-plugins.inc
DEPENDS += "gst-plugins-base libmusicbrainz tremor"
-PR = "r5"
+PR = "r6"
EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio \
--with-plugins=musicbrainz,wavpack,ivorbis"
@@ -8,3 +8,8 @@ EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disab
SRC_URI += " file://ivorbisdec.patch;patch=1;pnum=0"
ARM_INSTRUCTION_SET = "arm"
+
+do_configure_prepend() {
+ # This m4 file contains nastiness which conflicts with libtool 2.2.2
+ rm ${S}/m4/lib-link.m4 || true
+}
diff --git a/meta/packages/gstreamer/gst-plugins-base_0.10.17.bb b/meta/packages/gstreamer/gst-plugins-base_0.10.17.bb
index 68123bad6..013562233 100644
--- a/meta/packages/gstreamer/gst-plugins-base_0.10.17.bb
+++ b/meta/packages/gstreamer/gst-plugins-base_0.10.17.bb
@@ -6,3 +6,7 @@ PROVIDES_${PN} += "gst-plugins"
EXTRA_OECONF += "--disable-freetypetest --disable-pango --disable-theora"
+do_configure_prepend() {
+ # This m4 file contains nastiness which conflicts with libtool 2.2.2
+ rm ${S}/m4/lib-link.m4
+}
diff --git a/meta/packages/gstreamer/gst-plugins-good_0.10.6.bb b/meta/packages/gstreamer/gst-plugins-good_0.10.6.bb
index c8b48f3f2..995ab9ec9 100644
--- a/meta/packages/gstreamer/gst-plugins-good_0.10.6.bb
+++ b/meta/packages/gstreamer/gst-plugins-good_0.10.6.bb
@@ -1,6 +1,11 @@
require gst-plugins.inc
DEPENDS += "gst-plugins-base gconf cairo jpeg libpng gtk+ zlib libid3tag flac \
speex"
-PR="r1"
+PR = "r3"
EXTRA_OECONF += "--disable-aalib --disable-esd --disable-shout2 --disable-libcaca --without-check"
+
+do_configure_prepend() {
+ # This m4 file contains nastiness which conflicts with libtool 2.2.2
+ rm ${S}/m4/lib-link.m4 || true
+}
diff --git a/meta/packages/gstreamer/gst-plugins-ugly_0.10.6.bb b/meta/packages/gstreamer/gst-plugins-ugly_0.10.6.bb
index 56f46d713..b46500dae 100644
--- a/meta/packages/gstreamer/gst-plugins-ugly_0.10.6.bb
+++ b/meta/packages/gstreamer/gst-plugins-ugly_0.10.6.bb
@@ -1,7 +1,11 @@
require gst-plugins.inc
DEPENDS += "gst-plugins-base libid3tag libmad mpeg2dec liba52 lame"
-PR = "r3"
+PR = "r5"
SRC_URI += " file://lame-autoconf.patch;patch=1"
EXTRA_OECONF += "--with-plugins=a52dec,lame,id3tag,mad,mpeg2dec,mpegstream,mpegaudioparse,asfdemux,realmedia"
+do_configure_prepend() {
+ # This m4 file contains nastiness which conflicts with libtool 2.2.2
+ rm ${S}/m4/lib-link.m4 || true
+}
diff --git a/meta/packages/gstreamer/gstreamer_0.10.17.bb b/meta/packages/gstreamer/gstreamer_0.10.17.bb
index 80becb1a4..f608ca436 100644
--- a/meta/packages/gstreamer/gstreamer_0.10.17.bb
+++ b/meta/packages/gstreamer/gstreamer_0.10.17.bb
@@ -18,6 +18,11 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz
# file://gstreamer-0.9-binary-registry.patch;patch=1"
EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
+do_configure_prepend() {
+ # This m4 file contains nastiness which conflicts with libtool 2.2.2
+ rm ${S}/common/m4/lib-link.m4 || true
+}
+
#do_compile_prepend () {
# mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/
#}