summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-08-12 13:59:29 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-12 15:10:12 +0100
commitcf1e754b3fee3c7ae907e7ae30233083d7892215 (patch)
treebda80e7e109bc28cccc5fd9db3af11cfd231bd51
parentbb175ec20897281969012e6336eb5bd188e297c6 (diff)
downloadopenembedded-core-cf1e754b3fee3c7ae907e7ae30233083d7892215.tar.gz
openembedded-core-cf1e754b3fee3c7ae907e7ae30233083d7892215.tar.bz2
openembedded-core-cf1e754b3fee3c7ae907e7ae30233083d7892215.tar.xz
openembedded-core-cf1e754b3fee3c7ae907e7ae30233083d7892215.zip
libxml2: fix python binding
--with-python= should be followed by the path to python binary, not prefix, also export several environment for passing building, fixes [BUGID #69] Signed-off-by: Qing He <qing.he@intel.com>
-rw-r--r--meta/packages/libxml/libxml2.inc8
-rw-r--r--meta/packages/libxml/libxml2_2.7.7.bb2
2 files changed, 8 insertions, 2 deletions
diff --git a/meta/packages/libxml/libxml2.inc b/meta/packages/libxml/libxml2.inc
index 6a763aa4d..5aba6a787 100644
--- a/meta/packages/libxml/libxml2.inc
+++ b/meta/packages/libxml/libxml2.inc
@@ -19,7 +19,13 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
-EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_DIR_NATIVE}/${prefix} --without-debug --without-legacy --with-catalog --without-docbook --with-c14n"
+EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-debug --without-legacy --with-catalog --without-docbook --with-c14n"
+
+# required for pythong binding
+export HOST_SYS
+export BUILD_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
export LDFLAGS += "-ldl"
diff --git a/meta/packages/libxml/libxml2_2.7.7.bb b/meta/packages/libxml/libxml2_2.7.7.bb
index 7e017c6ee..deb28b395 100644
--- a/meta/packages/libxml/libxml2_2.7.7.bb
+++ b/meta/packages/libxml/libxml2_2.7.7.bb
@@ -1,3 +1,3 @@
require libxml2.inc
-PR = "r0"
+PR = "r1"