summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-02 14:31:30 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-02 14:31:30 +0000
commitdd5269c3299fe94fa4c9cbb8c953f7f1737ee921 (patch)
treeb09ccf71948183bd422559f5eb92c344c99f19a2
parent10b89e872c3b15d4e270be2233423cef7392f457 (diff)
downloadopenembedded-core-dd5269c3299fe94fa4c9cbb8c953f7f1737ee921.tar.gz
openembedded-core-dd5269c3299fe94fa4c9cbb8c953f7f1737ee921.tar.bz2
openembedded-core-dd5269c3299fe94fa4c9cbb8c953f7f1737ee921.tar.xz
openembedded-core-dd5269c3299fe94fa4c9cbb8c953f7f1737ee921.zip
parted: 1.88 -> 1.9.0 (works with recent autoconf/automake)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta/packages/parted/parted-1.9.0/no_check.patch (renamed from meta/packages/parted/parted-1.8.8/no_check.patch)13
-rw-r--r--meta/packages/parted/parted-1.9.0/syscalls.patch (renamed from meta/packages/parted/parted-1.8.8/syscalls.patch)14
-rw-r--r--meta/packages/parted/parted_1.9.0.bb (renamed from meta/packages/parted/parted_1.8.8.bb)2
3 files changed, 15 insertions, 14 deletions
diff --git a/meta/packages/parted/parted-1.8.8/no_check.patch b/meta/packages/parted/parted-1.9.0/no_check.patch
index 22d364a0a..24a328cee 100644
--- a/meta/packages/parted/parted-1.8.8/no_check.patch
+++ b/meta/packages/parted/parted-1.9.0/no_check.patch
@@ -3,15 +3,16 @@ it to be disabled.
RP - 4/11/08
-Index: parted-1.8.8/configure.ac
+Index: parted-1.9.0/configure.ac
===================================================================
---- parted-1.8.8.orig/configure.ac 2008-11-04 15:18:17.000000000 +0000
-+++ parted-1.8.8/configure.ac 2008-11-04 15:18:31.000000000 +0000
-@@ -481,6 +481,6 @@
- AM_CONDITIONAL([COMPILE_FOR_S390], [test "$compile_for_s390" = "yes"])
+--- parted-1.9.0.orig/configure.ac 2009-07-23 18:52:08.000000000 +0100
++++ parted-1.9.0/configure.ac 2010-02-02 14:13:56.013905093 +0000
+@@ -477,7 +477,7 @@
+ AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux])
dnl check for "check", unit testing library/header
-PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)
+have_check=no
- if test "$have_scintilla" != "yes"; then
+ if test "$have_check" != "yes"; then
AC_MSG_RESULT([Unable to locate check version 0.9.3 or higher: not building])
+ fi
diff --git a/meta/packages/parted/parted-1.8.8/syscalls.patch b/meta/packages/parted/parted-1.9.0/syscalls.patch
index 042fc9769..6be49968f 100644
--- a/meta/packages/parted/parted-1.8.8/syscalls.patch
+++ b/meta/packages/parted/parted-1.9.0/syscalls.patch
@@ -2,20 +2,20 @@
libparted/arch/linux.c | 13 +++++++++++++
1 file changed, 13 insertions(+)
-Index: parted-1.8.8/libparted/arch/linux.c
+Index: parted-1.9.0/libparted/arch/linux.c
===================================================================
---- parted-1.8.8.orig/libparted/arch/linux.c 2007-08-09 20:47:57.000000000 +0200
-+++ parted-1.8.8/libparted/arch/linux.c 2008-10-06 13:49:17.000000000 +0200
-@@ -18,6 +18,8 @@
+--- parted-1.9.0.orig/libparted/arch/linux.c 2009-07-23 18:52:08.000000000 +0100
++++ parted-1.9.0/libparted/arch/linux.c 2010-02-02 14:14:16.523904768 +0000
+@@ -17,6 +17,8 @@
#define PROC_DEVICES_BUFSIZ 16384
+#include <linux/version.h>
+
#include <config.h>
+ #include <arch/linux.h>
- #include <parted/parted.h>
-@@ -1361,12 +1363,14 @@ linux_refresh_close (PedDevice* dev)
+@@ -1477,12 +1479,14 @@
#if SIZEOF_OFF_T < 8
@@ -30,7 +30,7 @@ Index: parted-1.8.8/libparted/arch/linux.c
loff_t
llseek (unsigned int fd, loff_t offset, unsigned int whence)
-@@ -1374,11 +1378,20 @@ llseek (unsigned int fd, loff_t offset,
+@@ -1490,11 +1494,20 @@
loff_t result;
int retval;
diff --git a/meta/packages/parted/parted_1.8.8.bb b/meta/packages/parted/parted_1.9.0.bb
index 620546076..2a95b9cea 100644
--- a/meta/packages/parted/parted_1.8.8.bb
+++ b/meta/packages/parted/parted_1.9.0.bb
@@ -9,6 +9,6 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
file://no_check.patch;patch=1 \
file://syscalls.patch;patch=1 "
-EXTRA_OECONF = "--disable-Werror"
+EXTRA_OECONF = "--disable-Werror --disable-device-mapper"
inherit autotools_stage pkgconfig gettext