summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-02 15:11:00 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-02 15:11:00 +0000
commite51fbab510c1a2228b61bfa9dd13e6b964cdc721 (patch)
tree0edbd514a229f89934bf74ecc35be78c0f10ccf1
parent5f02bb8379f520c15484bc01ce672047e37bf9c7 (diff)
downloadopenembedded-core-e51fbab510c1a2228b61bfa9dd13e6b964cdc721.tar.gz
openembedded-core-e51fbab510c1a2228b61bfa9dd13e6b964cdc721.tar.bz2
openembedded-core-e51fbab510c1a2228b61bfa9dd13e6b964cdc721.tar.xz
openembedded-core-e51fbab510c1a2228b61bfa9dd13e6b964cdc721.zip
abiword: added 2.5.2 from OE (disabled spellcheck, printing, plugins)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3064 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/abiword/abiword-2.5.inc63
-rw-r--r--meta/packages/abiword/abiword-embedded_2.5.2.bb10
-rw-r--r--meta/packages/abiword/abiword_2.5.2.bb5
3 files changed, 78 insertions, 0 deletions
diff --git a/meta/packages/abiword/abiword-2.5.inc b/meta/packages/abiword/abiword-2.5.inc
new file mode 100644
index 000000000..dcd3b8553
--- /dev/null
+++ b/meta/packages/abiword/abiword-2.5.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2"
+RDEPENDS = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+
+#want 2.x from 2.x.y for the installation directory
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/abiword-${SHRT_VER}/glade \
+ ${datadir}/abiword-${SHRT_VER}/scripts \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
+# ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \
+# ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
+ ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --disable-pspell \
+ --disable-spellcheck \
+ --disable-printing \
+ --disable-exports \
+ --with-sys-wv"
+
+# AbiWord configure.ac does not play nicely with autoreconf
+# so use the autogen.sh script that comes with AbiWord
+#
+do_configure() {
+ cd ${S}
+ export NOCONFIGURE="no"; ./autogen.sh
+ oe_runconf
+}
+
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
+
+FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
+FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
+FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
diff --git a/meta/packages/abiword/abiword-embedded_2.5.2.bb b/meta/packages/abiword/abiword-embedded_2.5.2.bb
new file mode 100644
index 000000000..47cf9e03c
--- /dev/null
+++ b/meta/packages/abiword/abiword-embedded_2.5.2.bb
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+
diff --git a/meta/packages/abiword/abiword_2.5.2.bb b/meta/packages/abiword/abiword_2.5.2.bb
new file mode 100644
index 000000000..566d0fa20
--- /dev/null
+++ b/meta/packages/abiword/abiword_2.5.2.bb
@@ -0,0 +1,5 @@
+require abiword-2.5.inc
+
+PR = "r1"
+
+RCONFLICTS = "abiword-embedded"