summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-09-02 23:03:24 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-05 20:24:55 +0100
commitf072ddc43828ebe8df4dd7433726775dd547580b (patch)
treeda9db1a97fd9e6c2b67997020edd8a6a345f3290
parent3016f8f13e86034cc1c5686fc01a3bf39eb33d79 (diff)
downloadopenembedded-core-f072ddc43828ebe8df4dd7433726775dd547580b.tar.gz
openembedded-core-f072ddc43828ebe8df4dd7433726775dd547580b.tar.bz2
openembedded-core-f072ddc43828ebe8df4dd7433726775dd547580b.tar.xz
openembedded-core-f072ddc43828ebe8df4dd7433726775dd547580b.zip
linux-yocto: generalize kernel config search pattern
After constructing a kernel configuration file it then needs to be located in the tree so it can be audited against the final .config. The previous string that was used for the search pattern contains the kernel version. If the recipe space kernel version and internal tree version are out of sync, this will cause the constructed config to not be found. By removing the version from the search string, we can still find out config and gracefully adapt to minor version skew. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/kernel-yocto.bbclass2
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index daaee500e..0f9226757 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -105,7 +105,7 @@ python do_kernel_configcheck() {
bb.plain("NOTE: validating kernel configuration")
pathprefix = "export PATH=%s; " % bb.data.getVar('PATH', d, True)
- cmd = bb.data.expand("cd ${B}/..; kconf_check -${LINUX_KERNEL_TYPE}-config-${LINUX_VERSION} ${B} ${S} ${B} ${KBRANCH}",d )
+ cmd = bb.data.expand("cd ${B}/..; kconf_check -${LINUX_KERNEL_TYPE}-config- ${B} ${S} ${B} ${KBRANCH}",d )
ret, result = commands.getstatusoutput("%s%s" % (pathprefix, cmd))
bb.plain( "%s" % result )
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 1649bbc41..edaaea6d2 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
DEPENDS = "git-native guilt-native"
-SRCREV = "eab0c4eeb9fdb3d83e7aca4b70334cc7b02540b6"
+SRCREV = "60723c84395a9ac1753589824e30be39a781bb82"
PR = r10
PV = "0.1+git${SRCPV}"