summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-06-21 11:19:55 +0000
committerChris Lord <chris@openedhand.com>2006-06-21 11:19:55 +0000
commitf3cf5eea1658e6782e53130089a6fcd4a4062197 (patch)
treea7d4a81d1869c1ce19274a2fe412599e24bfdc2c
parent0d229f1485dc5d752ea817e72c634bd132fb2b81 (diff)
downloadopenembedded-core-f3cf5eea1658e6782e53130089a6fcd4a4062197.tar.gz
openembedded-core-f3cf5eea1658e6782e53130089a6fcd4a4062197.tar.bz2
openembedded-core-f3cf5eea1658e6782e53130089a6fcd4a4062197.tar.xz
openembedded-core-f3cf5eea1658e6782e53130089a6fcd4a4062197.zip
Add glib-2.0-native 2.10.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@488 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0-native-2.10.3/glib-gettextize-dir.patch11
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb53
2 files changed, 64 insertions, 0 deletions
diff --git a/openembedded/packages/glib-2.0/glib-2.0-native-2.10.3/glib-gettextize-dir.patch b/openembedded/packages/glib-2.0/glib-2.0-native-2.10.3/glib-gettextize-dir.patch
new file mode 100644
index 000000000..efe332557
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0-native-2.10.3/glib-gettextize-dir.patch
@@ -0,0 +1,11 @@
+--- glib-2.10.3/glib-gettextize.in.old 2006-06-21 12:46:45.000000000 +0100
++++ glib-2.10.3/glib-gettextize.in 2006-06-21 12:48:14.000000000 +0100
+@@ -49,7 +49,7 @@
+ ;;
+ esac
+
+-gettext_dir=$prefix/share/glib-2.0/gettext
++gettext_dir=@datadir@/glib-2.0/gettext
+
+ while test $# -gt 0; do
+ case "$1" in
diff --git a/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb b/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb
new file mode 100644
index 000000000..d0a442eee
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS += "gtk-doc-native"
+
+EXTRA_OECONF = "--disable-debug"
+
+SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \
+ file://glib-gettextize-dir.patch;patch=1 \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig native gettext
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ install -m 0755 gobject/glib-mkenums ${STAGING_BINDIR}/
+ install -m 0755 gobject/.libs/glib-genmarshal ${STAGING_BINDIR}/
+ install -m 0755 glib-gettextize ${STAGING_BINDIR}/
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+ install -d ${STAGING_DATADIR}/glib-2.0/gettext/po
+ install -m 0755 mkinstalldirs ${STAGING_DATADIR}/glib-2.0/gettext/
+ install -m 0644 po/Makefile.in.in ${STAGING_DATADIR}/glib-2.0/gettext/po/
+}
+
+do_install () {
+ :
+}
+