summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-29 13:32:04 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-29 13:32:04 +0100
commitf9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9 (patch)
tree1ee1ed9eb7673f1556da0d52d14089a03d93f76f
parent132122e31375117bf8b5ab68369cb8fafa03058d (diff)
downloadopenembedded-core-f9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9.tar.gz
openembedded-core-f9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9.tar.bz2
openembedded-core-f9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9.tar.xz
openembedded-core-f9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9.zip
bitbake: Move the logger initialization from cooker to utils
In order to move the environment cleaning, which wants to log a message, before cooker creation, the logging facility initialization needs to happen earlier. So, it is now in init_logger in utils.py and called from bitbake before the creation of the data object. It also seems more correct to initialize a global facility like this from a more global context than the creation of an object, of which there could theoretically be many. Signed-off-by: Jeff Dike <jdike@linux.intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rwxr-xr-xbitbake/bin/bitbake3
-rw-r--r--bitbake/lib/bb/cooker.py11
-rw-r--r--bitbake/lib/bb/utils.py16
3 files changed, 19 insertions, 11 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 1a45ec4f7..0f4ff8817 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -152,6 +152,9 @@ Default BBFILES are the .bb files in the current directory.""" )
# server is daemonized this logfile will be truncated.
cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
+ bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
+ configuration.debug_domains)
+
cooker = bb.cooker.BBCooker(configuration, server)
# Clear away any spurious environment variables. But don't wipe the
diff --git a/bitbake/lib/bb/cooker.py b/bitbake/lib/bb/cooker.py
index 3881df484..2406dfe95 100644
--- a/bitbake/lib/bb/cooker.py
+++ b/bitbake/lib/bb/cooker.py
@@ -72,17 +72,6 @@ class BBCooker:
self.configuration = configuration
- if self.configuration.verbose:
- bb.msg.set_verbose(True)
-
- if self.configuration.debug:
- bb.msg.set_debug_level(self.configuration.debug)
- else:
- bb.msg.set_debug_level(0)
-
- if self.configuration.debug_domains:
- bb.msg.set_debug_domains(self.configuration.debug_domains)
-
self.configuration.data = bb.data.init()
bb.data.inheritFromOS(self.configuration.data)
diff --git a/bitbake/lib/bb/utils.py b/bitbake/lib/bb/utils.py
index ad0aa68b2..40326f98d 100644
--- a/bitbake/lib/bb/utils.py
+++ b/bitbake/lib/bb/utils.py
@@ -614,3 +614,19 @@ def which(path, item, direction = 0):
return next
return ""
+
+def init_logger(logger, verbose, debug, debug_domains):
+ """
+ Set verbosity and debug levels in the logger
+ """
+
+ if verbose:
+ logger.set_verbose(True)
+
+ if debug:
+ logger.set_debug_level(debug)
+ else:
+ logger.set_debug_level(0)
+
+ if debug_domains:
+ logger.set_debug_domains(debug_domains)