summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-20 13:10:38 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-20 13:10:38 +0000
commitfa334003652967769b9b47c3f172fe1079c278bf (patch)
tree4143eb230d72d089e9e405b88af25bc42556d136
parent1e90da6731753b228739a2b7abf336e403a9bd96 (diff)
downloadopenembedded-core-fa334003652967769b9b47c3f172fe1079c278bf.tar.gz
openembedded-core-fa334003652967769b9b47c3f172fe1079c278bf.tar.bz2
openembedded-core-fa334003652967769b9b47c3f172fe1079c278bf.tar.xz
openembedded-core-fa334003652967769b9b47c3f172fe1079c278bf.zip
automake: finish updating to 1.10, move some content between files to clean up
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4105 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/automake/automake-native.inc4
-rw-r--r--meta/packages/automake/automake.inc39
-rw-r--r--meta/packages/automake/automake_1.10.bb45
3 files changed, 45 insertions, 43 deletions
diff --git a/meta/packages/automake/automake-native.inc b/meta/packages/automake/automake-native.inc
index 7b69252ff..8b64af309 100644
--- a/meta/packages/automake/automake-native.inc
+++ b/meta/packages/automake/automake-native.inc
@@ -1,5 +1,5 @@
-SECTION = "devel"
-include automake_${PV}.bb
+require automake.inc
+
DEPENDS = "autoconf-native"
RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
diff --git a/meta/packages/automake/automake.inc b/meta/packages/automake/automake.inc
index fa59c1f5c..ab2edf26b 100644
--- a/meta/packages/automake/automake.inc
+++ b/meta/packages/automake/automake.inc
@@ -1,23 +1,16 @@
-RDEPENDS_automake += "\
- autoconf \
- perl \
- perl-module-bytes \
- perl-module-constant \
- perl-module-cwd \
- perl-module-data-dumper \
- perl-module-dynaloader \
- perl-module-errno \
- perl-module-exporter-heavy \
- perl-module-file-basename \
- perl-module-file-compare \
- perl-module-file-copy \
- perl-module-file-glob \
- perl-module-file-spec-unix \
- perl-module-file-stat \
- perl-module-getopt-long \
- perl-module-io \
- perl-module-io-file \
- perl-module-posix \
- perl-module-strict \
- perl-module-text-parsewords \
- perl-module-vars "
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 "
+
+S = "${WORKDIR}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
diff --git a/meta/packages/automake/automake_1.10.bb b/meta/packages/automake/automake_1.10.bb
index 1235c1096..4c54d069c 100644
--- a/meta/packages/automake/automake_1.10.bb
+++ b/meta/packages/automake/automake_1.10.bb
@@ -1,29 +1,38 @@
-DESCRIPTION = "A tool for automatically generating Makefiles."
-LICENSE = "GPL"
-HOMEPAGE = "http://www.gnu.org/software/automake/"
-SECTION = "devel"
-
-SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
- ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
-
-S = "${WORKDIR}/automake-${PV}"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
-
-inherit autotools
+require automake.inc
-export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
-FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
-require automake.inc
+SRC_URI += "file://path_prog_fixes.patch;patch=1"
do_install () {
oe_runmake 'DESTDIR=${D}' install
install -d ${D}${datadir}
if [ ! -e ${D}${datadir}/aclocal ]; then
- ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ ln -sf aclocal-1.10 ${D}${datadir}/aclocal
fi
if [ ! -e ${D}${datadir}/automake ]; then
- ln -sf automake-1.9 ${D}${datadir}/automake
+ ln -sf automake-1.10 ${D}${datadir}/automake
fi
}