summaryrefslogtreecommitdiff
path: root/bitbake-dev/bin/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-14 17:36:31 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-14 23:29:31 +0000
commitf00e5cf964d0ea48d517f0b8f9ca2aba646ea807 (patch)
treec2bc884ee3192895549745326c2752fe7200a206 /bitbake-dev/bin/bitbake
parenta7740492afa04d9a1bdcb907df91900d251fa29f (diff)
downloadopenembedded-core-f00e5cf964d0ea48d517f0b8f9ca2aba646ea807.tar.gz
openembedded-core-f00e5cf964d0ea48d517f0b8f9ca2aba646ea807.tar.bz2
openembedded-core-f00e5cf964d0ea48d517f0b8f9ca2aba646ea807.tar.xz
openembedded-core-f00e5cf964d0ea48d517f0b8f9ca2aba646ea807.zip
bitbake-dev: Sync with upstream
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bitbake-dev/bin/bitbake')
-rwxr-xr-xbitbake-dev/bin/bitbake14
1 files changed, 9 insertions, 5 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index 34c49b8c5..cabdf2b45 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -144,7 +144,11 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
- cooker = bb.cooker.BBCooker(configuration)
+ # Save a logfile for cooker into the current working directory. When the
+ # server is daemonized this logfile will be truncated.
+ cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
+
+ cooker = bb.cooker.BBCooker(configuration, bb.server.xmlrpc)
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
@@ -152,13 +156,13 @@ Default BBFILES are the .bb files in the current directory.""" )
bb.utils.clean_environment()
cooker.parseCommandLine()
+
+
+
+
host = cooker.server.host
port = cooker.server.port
- # Save a logfile for cooker into the current working directory. When the
- # server is daemonized this logfile will be truncated.
- cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
-
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker