summaryrefslogtreecommitdiff
path: root/bitbake-dev/bin
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2008-10-28 11:09:51 +0000
committerRob Bradford <rob@linux.intel.com>2008-10-28 11:40:03 +0000
commit0b9da42bb5c2355fe6b2a71f3a4970ac46118caa (patch)
tree8e62f6a148f4d61ff6c9e6cca084a5de572076a1 /bitbake-dev/bin
parent23f08fdde338f95966842fc53c16e98a8418bbb7 (diff)
downloadopenembedded-core-0b9da42bb5c2355fe6b2a71f3a4970ac46118caa.tar.gz
openembedded-core-0b9da42bb5c2355fe6b2a71f3a4970ac46118caa.tar.bz2
openembedded-core-0b9da42bb5c2355fe6b2a71f3a4970ac46118caa.tar.xz
openembedded-core-0b9da42bb5c2355fe6b2a71f3a4970ac46118caa.zip
bitbake-dev: Save the cooker log into the working directory.
This is necessary since with later refactoring the TMPDIR variable will not be available at this point in time.
Diffstat (limited to 'bitbake-dev/bin')
-rwxr-xr-xbitbake-dev/bin/bitbake12
1 files changed, 4 insertions, 8 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index d85135a11..3e8782597 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -130,17 +130,13 @@ Default BBFILES are the .bb files in the current directory.""" )
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
- cooker.parseConfiguration()
+ cooker.parseCommandLine()
host = cooker.server.host
port = cooker.server.port
- # Save a logfile for cooker somewhere
- t = bb.data.getVar('TMPDIR', cooker.configuration.data, True)
- if not t:
- bb.msg.fatal(bb.msg.domain.Build, "TMPDIR not set")
- t = os.path.join(t, "cooker")
- bb.mkdirhier(t)
- cooker_logfile = "%s/log.cooker.%s" % (t, str(os.getpid()))
+ # Save a logfile for cooker into the current working directory. When the
+ # server is daemonized this logfile will be truncated.
+ cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker