summaryrefslogtreecommitdiff
path: root/bitbake/contrib/vim/plugin
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-02-23 10:48:51 -0800
committerKhem Raj <raj.khem@gmail.com>2011-02-23 10:48:51 -0800
commit951cbf3f65f347c7a7bbcae193218f9187a15fbf (patch)
tree96e9c74551e6931804992f8f49af05f732eb0fff /bitbake/contrib/vim/plugin
parentadbaae2179a6c3746e53f7fbb2ca0939e85a7ea9 (diff)
downloadopenembedded-core-951cbf3f65f347c7a7bbcae193218f9187a15fbf.tar.gz
openembedded-core-951cbf3f65f347c7a7bbcae193218f9187a15fbf.tar.bz2
openembedded-core-951cbf3f65f347c7a7bbcae193218f9187a15fbf.tar.xz
openembedded-core-951cbf3f65f347c7a7bbcae193218f9187a15fbf.zip
bitbake: Remove in-tree version
Bitbake should be used by checking it out from its own repo Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'bitbake/contrib/vim/plugin')
-rwxr-xr-xbitbake/contrib/vim/plugin/newbb.vim85
1 files changed, 0 insertions, 85 deletions
diff --git a/bitbake/contrib/vim/plugin/newbb.vim b/bitbake/contrib/vim/plugin/newbb.vim
deleted file mode 100755
index afba1d9aa..000000000
--- a/bitbake/contrib/vim/plugin/newbb.vim
+++ /dev/null
@@ -1,85 +0,0 @@
-" Vim plugin file
-" Purpose: Create a template for new bb files
-" Author: Ricardo Salveti <rsalveti@gmail.com>
-" Copyright: Copyright (C) 2008 Ricardo Salveti <rsalveti@gmail.com>
-"
-" This file is licensed under the MIT license, see COPYING.MIT in
-" this source distribution for the terms.
-"
-" Based on the gentoo-syntax package
-"
-" Will try to use git to find the user name and email
-
-if &compatible || v:version < 600
- finish
-endif
-
-fun! <SID>GetUserName()
- let l:user_name = system("git-config --get user.name")
- if v:shell_error
- return "Unknow User"
- else
- return substitute(l:user_name, "\n", "", "")
-endfun
-
-fun! <SID>GetUserEmail()
- let l:user_email = system("git-config --get user.email")
- if v:shell_error
- return "unknow@user.org"
- else
- return substitute(l:user_email, "\n", "", "")
-endfun
-
-fun! BBHeader()
- let l:current_year = strftime("%Y")
- let l:user_name = <SID>GetUserName()
- let l:user_email = <SID>GetUserEmail()
- 0 put ='# Copyright (C) ' . l:current_year .
- \ ' ' . l:user_name . ' <' . l:user_email . '>'
- put ='# Released under the MIT license (see COPYING.MIT for the terms)'
- $
-endfun
-
-fun! NewBBTemplate()
- let l:paste = &paste
- set nopaste
-
- " Get the header
- call BBHeader()
-
- " New the bb template
- put ='DESCRIPTION = \"\"'
- put ='HOMEPAGE = \"\"'
- put ='LICENSE = \"\"'
- put ='SECTION = \"\"'
- put ='DEPENDS = \"\"'
- put ='PR = \"r0\"'
- put =''
- put ='SRC_URI = \"\"'
-
- " Go to the first place to edit
- 0
- /^DESCRIPTION =/
- exec "normal 2f\""
-
- if paste == 1
- set paste
- endif
-endfun
-
-if !exists("g:bb_create_on_empty")
- let g:bb_create_on_empty = 1
-endif
-
-" disable in case of vimdiff
-if v:progname =~ "vimdiff"
- let g:bb_create_on_empty = 0
-endif
-
-augroup NewBB
- au BufNewFile *.bb
- \ if g:bb_create_on_empty |
- \ call NewBBTemplate() |
- \ endif
-augroup END
-