summaryrefslogtreecommitdiff
path: root/bitbake/lib/bb/parse/parse_py
diff options
context:
space:
mode:
authorHolger Freyther <ich@tamarin.(none)>2009-05-17 13:00:42 +0200
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-10 16:32:28 +0000
commitb045ab32227baaec940698dad79aac0e41c5ee8a (patch)
treea3ea40cbaca9b34b07320029793a0c08db0a952e /bitbake/lib/bb/parse/parse_py
parent7477c0d89a84994f78a1cf1a7ac973bead72073a (diff)
downloadopenembedded-core-b045ab32227baaec940698dad79aac0e41c5ee8a.tar.gz
openembedded-core-b045ab32227baaec940698dad79aac0e41c5ee8a.tar.bz2
openembedded-core-b045ab32227baaec940698dad79aac0e41c5ee8a.tar.xz
openembedded-core-b045ab32227baaec940698dad79aac0e41c5ee8a.zip
bitbake: [parse] Move inherit handling to method
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bitbake/lib/bb/parse/parse_py')
-rw-r--r--bitbake/lib/bb/parse/parse_py/BBHandler.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/bitbake/lib/bb/parse/parse_py/BBHandler.py b/bitbake/lib/bb/parse/parse_py/BBHandler.py
index 6cb8d560f..47502adc3 100644
--- a/bitbake/lib/bb/parse/parse_py/BBHandler.py
+++ b/bitbake/lib/bb/parse/parse_py/BBHandler.py
@@ -168,6 +168,11 @@ def handleBBHandlers(m, d):
data.setVarFlag(h, "handler", 1, d)
data.setVar('__BBHANDLERS', bbhands, d)
+def handleInherit(m, d):
+ files = m.group(1)
+ n = __word__.findall(files)
+ inherit(n, d)
+
def supports(fn, d):
return fn[-3:] == ".bb" or fn[-8:] == ".bbclass" or fn[-4:] == ".inc"
@@ -376,10 +381,7 @@ def feeder(lineno, s, fn, root, d):
m = __inherit_regexp__.match(s)
if m:
-
- files = m.group(1)
- n = __word__.findall(files)
- inherit(n, d)
+ handleInherit(m, d)
return
from bb.parse import ConfHandler