summaryrefslogtreecommitdiff
path: root/bitbake/lib/bb/runqueue.py
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-20 12:09:31 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-20 12:09:31 +0000
commit079e6825aacec7ef9b3976c9057363b690a43ce5 (patch)
treeb25054c486e11d0b293e2166f1c4cdce02eb8704 /bitbake/lib/bb/runqueue.py
parent027c071fc5fbaed003d17e1d385008a5b70ee3eb (diff)
downloadopenembedded-core-079e6825aacec7ef9b3976c9057363b690a43ce5.tar.gz
openembedded-core-079e6825aacec7ef9b3976c9057363b690a43ce5.tar.bz2
openembedded-core-079e6825aacec7ef9b3976c9057363b690a43ce5.tar.xz
openembedded-core-079e6825aacec7ef9b3976c9057363b690a43ce5.zip
bitbake: sync with upstream stable branch bugfixes and enhancements
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3554 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake/lib/bb/runqueue.py')
-rw-r--r--bitbake/lib/bb/runqueue.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/bitbake/lib/bb/runqueue.py b/bitbake/lib/bb/runqueue.py
index 68ef3a722..9d27d539c 100644
--- a/bitbake/lib/bb/runqueue.py
+++ b/bitbake/lib/bb/runqueue.py
@@ -564,7 +564,7 @@ class RunQueue:
# Check to make sure we still have tasks to run
if len(self.runq_fnid) == 0:
if not taskData.abort:
- bb.msg.note(1, bb.msg.domain.RunQueue, "All possible tasks have been run but build incomplete (--continue mode). See errors above for incomplete tasks.")
+ bb.msg.note(1, bb.msg.domain.RunQueue, "All buildable tasks have been run but the build is incomplete (--continue mode). Errors for the tasks that failed will have been printed above.")
return
bb.msg.fatal(bb.msg.domain.RunQueue, "No active tasks and not in --continue mode?! Please report this bug.")
@@ -630,7 +630,7 @@ class RunQueue:
for prov in prov_list:
if len(prov_list[prov]) > 1 and prov not in self.multi_provider_whitelist:
error = True
- bb.msg.error(bb.msg.domain.RunQueue, "Multiple files due to be built which all provide %s (%s)" % (prov, " ".join(prov_list[prov])))
+ bb.msg.error(bb.msg.domain.RunQueue, "Multiple .bb files are due to be built which each provide %s (%s).\n This usually means one provides something the other doesn't and should." % (prov, " ".join(prov_list[prov])))
#if error:
# bb.msg.fatal(bb.msg.domain.RunQueue, "Corrupted metadata configuration detected, aborting...")