summaryrefslogtreecommitdiff
path: root/bitbake/lib
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-11-14 13:08:03 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2011-01-04 14:46:39 +0000
commitb44100eafc76c0535d694a75bd5e195d5d6016b0 (patch)
tree645508a3821e983e670d3557fcfb268f7f6b8c4e /bitbake/lib
parent1d8a9b88560d27b79f88c37cecc4a7d386182db2 (diff)
downloadopenembedded-core-b44100eafc76c0535d694a75bd5e195d5d6016b0.tar.gz
openembedded-core-b44100eafc76c0535d694a75bd5e195d5d6016b0.tar.bz2
openembedded-core-b44100eafc76c0535d694a75bd5e195d5d6016b0.tar.xz
openembedded-core-b44100eafc76c0535d694a75bd5e195d5d6016b0.zip
BBHandler: simplify supports()
(Bitbake rev: 858d704d713d15bf97053eb1374758c74b0d8874) Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bitbake/lib')
-rw-r--r--bitbake/lib/bb/parse/parse_py/BBHandler.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/bitbake/lib/bb/parse/parse_py/BBHandler.py b/bitbake/lib/bb/parse/parse_py/BBHandler.py
index 31f44f7df..ac981b834 100644
--- a/bitbake/lib/bb/parse/parse_py/BBHandler.py
+++ b/bitbake/lib/bb/parse/parse_py/BBHandler.py
@@ -65,7 +65,8 @@ IN_PYTHON_EOF = -9999999999999
def supports(fn, d):
- return fn[-3:] == ".bb" or fn[-8:] == ".bbclass" or fn[-4:] == ".inc"
+ """Return True if fn has a supported extension"""
+ return os.path.splitext(fn)[-1] in [".bb", ".bbclass", ".inc"]
def inherit(files, d):
__inherit_cache = data.getVar('__inherit_cache', d) or []